Host Account Cache Needs to Start Before SnaServer Service (236849)



The information in this article applies to:

  • Microsoft SNA Server 3.0
  • Microsoft SNA Server 3.0 SP1
  • Microsoft SNA Server 3.0 SP2
  • Microsoft SNA Server 3.0 SP3
  • Microsoft SNA Server 4.0
  • Microsoft SNA Server 4.0 SP1
  • Microsoft SNA Server 4.0 SP2

This article was previously published under Q236849

SYMPTOMS

Applications that use the Single Sign-on feature of SNA Server may fail to open a session with the remote node because of a bad password. SnaServer internal and message traces will show that password substitution is not occurring while the Host Account Cache Service (SnaDatabase) is running on the Windows NT primary domain controller. The problem only occurs when the servers hosting the SNA Server and the Host Account Cache services are rebooted.

CAUSE

The SnaServer service checks for an existing Host Account Cache service in the Windows NT domain at startup time. If no Host Account Cache can be found within a minute, the SnaServer service assumes that no Host Account Cache has been installed in that domain and does not check again until it is restarted.

RESOLUTION

To resolve this problem, obtain the latest service pack for SNA Server version 4.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

215838 How to Obtain the Latest SNA Server Version 4.0 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Microsoft SNA Server version 3.0, 3.0 SP1, 3.0 SP2, 3.0 SP3, 4.0, 4.0 SP1, and 4.0 SP2. This problem was first corrected in SNA Server version 4.0 Service Pack 3.

Modification Type:MinorLast Reviewed:9/22/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE kbsna400sp3fix KB236849