You may receive an "Internal error 2336" error message that is caused by temporary folder files or settings when you install Office 2000 (236821)



The information in this article applies to:

  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professoinal
  • Microsoft Office 2000 Standard
  • Microsoft Office 2000 Small Business
  • Microsoft Office 2000 Developer
  • Microsoft Access 2000
  • Microsoft Excel 2000
  • Microsoft FrontPage 2000
  • Microsoft Outlook 2000
  • Microsoft PowerPoint 2000
  • Microsoft Word 2000

This article was previously published under Q236821
WARNING:This information is preliminary and has not been confirmed or tested by Microsoft. Use only with discretion.

SYMPTOMS

When you install Microsoft Office 2000, you may receive the following error message:
Internal error 2336: Please Contact Product Support for assistance.

CAUSE

Microsoft Office 2000 Setup cannot access your temporary files folder ("Temp folder"). The cause of this problem may be one of the following:
  • The Temp folder is missing or invalid.
  • You have insufficient permissions to the Temp folder on a computer that runs Microsoft Windows NT and the NTFS file system.
  • There are too many temporary files in the Temp folder.
The typical path for the temporary files folder is C:\Windows\Temp for Microsoft Windows 95 and Microsoft Windows 98, and C:\Temp for Windows NT.

RESOLUTION

To resolve this problem, use the appropriate methods for your situation.

Confirm the Temp Folder Is Valid

In Windows 95 or Windows 98

If you are using Windows 95 or Windows 98, follow these steps to confirm that your temp folder is valid:
  1. Restart your computer to a command prompt.

    In Windows 95, press F8 when you see the "Starting Windows 95" message, and then select Safe Mode Command Prompt Only on the Startup menu.

    In Windows 98, restart your computer, hold down CTRL after your computer completes the Power On Self Test (POST), and then select Safe Mode Command Prompt Only on the startup menu.
  2. Type set and press ENTER. Note the location of the TEMP variable.
  3. Change to the folder noted in step 2. For example, if TEMP is set to C:\Windows\Temp, type the following line and then press ENTER:

    cd \windows\temp

  4. Delete any temporary files in this folder. Temporary files typically have a .tmp extension. To delete these files, type the following line and then press ENTER:

    del *.tmp

  5. Move any remaining files to another temporary folder. To move these files, type each of the following lines, and press ENTER after each line:

    cd \
    md tempbak
    cd tempbak
    copy c:\windows\temp\*.*
    cd \
    cd \windows\temp
    del *.*

    Press Y and then press ENTER to confirm deleting the files.

    Note You should not delete these files from within the Windows graphical user interface (GUI) because Windows or a Windows-based program may be using one of these files.

  6. Restart your computer.

In Microsoft Windows NT 4.0

If you are using Microsoft Windows NT 4.0, follow these steps to confirm that your temp folder is valid:
  1. Click Start, point to Settings, and then click Control Panel.
  2. In Control Panel, double-click the System icon. When the System Properties dialog box appears, click the Environment tab. This tab lists the current System and User variables. Look under the User variables for the TEMP and TMP environment variable settings. Ensure that the folders referenced by these variables exist and have valid folder names. Also ensure that the hard disk on which the folders are located has at least 3 megabytes (MB) of free hard disk space and that you have read/write permissions to those folders.

Confirm Permissions to the Temp Folder on Windows NT

Make sure you have Full Control permissions to the \TEMP folder if your operating system is Windows NT.
  1. In Windows NT Explorer, right-click the \Temp folder, and then click Properties.
  2. Click the Security tab.
  3. Click Permissions.
  4. At this point, you are viewing the list of users and groups and their permissions. Make sure that you have Full Control permissions as a member of a group or explicitly. If not, click Add to add yourself to the list, or click Full Control in the Type of Access list for the appropriate user or group. See your Windows NT documentation for more information.

If None of These Resolutions Work

If the previous methods do not resolve the problem, create a verbose log file and contact Microsoft Technical Support. To create the verbose log file during Setup, type the following command line:

path\setup.exe /l*v c:\Officelog.txt

The above command line creates the verbose log file Officelog.txt on the root of drive C. You can specify any path and file name for this log file.

Modification Type:MinorLast Reviewed:10/13/2006
Keywords:kbtshoot kbsetup kberrmsg kbprb kbpubtypekc kbmsccsearch KB236821