Spooler Service Stops When Using Windows 95/98 Printer Driver (236293)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 4.0

This article was previously published under Q236293

SYMPTOMS

On your computer running Windows NT, the Spooler service may stop responding (hang) and one or more of the following error messages may be appear in the Event Viewer System log:
Spoolss.exe. Initialization of the dynamic link library failed.

%SystemRoot%\System32\Hpbcom.dll failed - the process is terminating abnormally.

CAUSE

These error messages may indicate that your computer is attempting to use an incorrect third-party printer driver. The Hpbcom.dll file is part of the Hewlett Packard (HP) JetAdmin software for Windows 95 or Windows 98. This software is not supported on Windows NT Server or Windows NT Workstation even though you can successfully install this software on Windows NT.

RESOLUTION

To resolve this issue, remove the JetAdmin software:
  1. Click Start, point to Settings, click Control Panel, and then double-click Add/Remove Programs.
  2. Click to select the JetAdmin software from the list of installed software, and then click Add/Remove.
  3. Click Yes, click Yes when prompted to remove the shared files that are no longer in use, and then click Yes to restart the computer.




NOTE: JetDirect is no longer supported by HP. SDI (Simple Device Installation) is now used to install network printers. For more information on this, see:


Modification Type:MajorLast Reviewed:7/13/2006
Keywords:kb3rdparty kberrmsg kbprb kbprint KB236293