OL98: News Reader Menu Command Is Missing After Upgrade to Internet Explorer 5 (235505)



The information in this article applies to:

  • Microsoft Outlook 98
  • the operating system: Microsoft Windows NT 4.0 SP5

This article was previously published under Q235505
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

After upgrading to Microsoft Internet Explorer 5 from Internet Explorer 4.x, the News menu command is no longer available on the Go menu in Outlook. The News menu command cannot be added by customizing either the toolbars or menus.

CAUSE

There is an incorrect entry in the registry.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

There are three methods to correct the problem:
  • Export the registry key before installing or upgrading to Internet Explorer 5.
  • Modify the registry after you have installed Internet Explorer 5.
  • Upgrade to Microsoft Office 2000.


If you have upgraded to Internet Explorer 5, you can uninstall it to return to Internet Explorer 4.0. Export the registry key from Internet Explorer 4.0, install Internet Explorer 5, and then import the registry key. If there is no previous version of Internet Explorer installed on the computer, use the second method to modify the registry.

Export the Registry Key Before Installing Internet Explorer 5

Before installing Internet Explorer 5 you will need to export the current registry key, and then re-register the key after Internet Explorer 5 has been installed. To do this, follow these steps:
  1. On the Start menu, click Run.
  2. type regedit and then click OK.
  3. Navigate to and click to select the following registry key:

    HKEY_LOCAL_MACHINE\Software\Clients\News\

  4. On the Registry menu, click Export Registry File.
  5. In the Save In box, click to select Desktop.
  6. In the File name box, type IE, and then click Save.
  7. Quit the registry editor and install Internet Explorer 5.
  8. When setup is complete, double-click the IE registry icon on the desktop.
The news reader will now function properly.

Modify the Registry Key After Installing Internet Explorer 5

If you have already installed Internet Explorer 5 to a non-system root drive, you will need to modify two registry keys. To do so, follow these steps:
  1. On the Start menu, click Run.
  2. type regedit and then click OK.
  3. Navigate to and click to select the following registry key:

    HKEY_LOCAL_MACHINE\Software\Clients\News\Microsoft Outlook\Protocols\news\shell\open\command

  4. Click to select the Default entry in the right-hand window.
  5. On the Edit menu, click Modify.
  6. In the Value Data box, change %SystemDrive%, to the drive letter where Internet Explorer 5 is installed. For example, if you installed Internet Explorer 5 to the D drive, the entry would look like this:

    "D:\Program Files\Outlook Express\MSIMN.EXE" /outnews /newsurl:%1

  7. Navigate to and click to select the following registry key:

    HKEY_LOCAL_MACHINE\Software\Clients\News\Outlook Express\Protocols\news\shell\open\command

  8. Click to select the Default entry in the right-hand window.
  9. On the Edit menu, click Modify.
  10. In the Value Data box, change %SystemDrive%, to the drive letter where Internet Explorer 5 is installed. For example, if you installed Internet Explorer 5 to the D drive, the entry would look like this:

    "D:\Program Files\Outlook Express\MSIMN.EXE" /outnews /newsurl:%1

  11. Quit the registry editor.
The news reader will now function correctly.

MORE INFORMATION

This problem occurs if you install Internet Explorer 5 to a drive other than the C drive (root system drive). Outlook Express 5 is used by Outlook as the news reader and is installed during the installation of Internet Explorer 5.

Modification Type:MajorLast Reviewed:6/11/2002
Keywords:kbprb KB235505