Possible Data Loss Writing to Network Drive with No Available Disk Space (235274)



The information in this article applies to:

  • Microsoft Windows 98
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 95

This article was previously published under Q235274

SYMPTOMS

A zero-byte file is created when you write to a network drive that has no available disk space. Either the remote drive is completely full, or quota software is installed and you have no quota free.

CAUSE

Data written by the Client for Microsoft Networks (VRedir) is cached by the protected-mode cache component (VCache). An error code is not returned to the program writing the data unless VCache cannot cache the data properly. The data in the cache is later flushed and written to the remote network drive, but the program does not receive the error code if an error occurs, and you are unaware that the remote file was not written correctly.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date      Time       Version      Size     File name     Platform
   -------------------------------------------------------------------
   6/03/99   6:55:58P   4.10.2149    165,461  Vredir.vxd    Windows 98
   2/08/99   5:48P      4.0.1120     156,773  Vredir.vxd    Windows 95
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was corrected in Windows 98 Second Edition.

MORE INFORMATION

For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

206071 General Information About Windows 98 and Windows 98 Second Edition Hotfixes

For additional information about Windows 95 hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

161020 Implementing Windows 95 Updates


Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbprb kbQFE KB235274