XADM: Too Many Consecutive CRLF Characters Truncate Message or Cause Information Store to Stop Responding (235219)



The information in this article applies to:

  • Microsoft Exchange Server 5.5

This article was previously published under Q235219

SYMPTOMS

If the IMS receives an inbound SMTP message that includes a large number of consecutive carriage-return line-feed (CRLF) characters in Japanese encoding, the message may be truncated at the CRLF characters, or the Information Store may stop responding. If the message is very large, stack overflow occurs and the Information Store stops responding.

CAUSE

When a whole series of CRLF characters are copied at one time, the operation will fail if the CRLF characters do not fit in the output buffer. On the other hand, if the free space in the output buffer exceeds the margin (256 bytes), the buffer is not reallocated. This problem always occurs when the series of CRLF characters exceeds the buffer size (4096 bytes = 2048 CRLF pairs), and in certain circumstances, it may occur with as little as 128 CRLF pairs, or with any number in between.

RESOLUTION

To resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

191014 XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack

The English version of this fix should have the following file attributes or later:

Component: Information Store

File nameVersion
Gapi32.dll5.5.2637.0
Mdbmsg.dll5.5.2637.0
Netif.dll5.5.2637.0
Store.exe5.5.2637.0

Component: Directory

File nameVersion
Dsamain.exe5.5.2600.0

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange Server version 5.5. This problem was first corrected in Exchange Server 5.5 Service Pack 3.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE EXC55SP3Fix kbbug kbfix kbQFE KB235219