You receive the "<Path> is not a valid Office add-in" error message when you start Outlook 2000 or Outlook 2002 (235009)



The information in this article applies to:

  • Microsoft Outlook 2002
  • Microsoft Outlook 2000

This article was previously published under Q235009
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you start Microsoft Outlook 2000 or Microsoft Outlook 2002, you receive an error message that is similar to the following:
Path is not a valid Office add-in.
This typically occurs when you install Microsoft Office 2000 to a folder other than the default folder. This issue affects all versions of Office 2000.

When you start Microsoft Outlook 2000, you receive an error message that is similar to the following:
The add-in <Drive>:\Program Files\Microsoft Office\Office\Sbcmsync.dll could not be installed or loaded. This problem may be resolved by using Detect & Repair. You may be out of memory, out of system resources, or missing a .dll file.

CAUSE

The registry entries for Small Business Customer Manager are set during installation of Small Business Tools, but the program files are not yet installed.

RESOLUTION

NOTE: There are several methods to resolve this problem, depending on your particular configuration. Please read this entire article prior to trying any of these procedures. The procedures are listed in order from easiest to most difficult.

Initially, the error message may be avoided by deactivating the Outlook Sync add-in following these steps:
  1. On the Tools menu, click Options and then click the Other tab.
  2. Click Advanced Options and then click Add-in Manager.
  3. Clear the Outlook Sync option, click OK three times, and then restart Outlook.
If the startup error persists, exit Outlook, rename the Extend.dat file, and then restart Outlook. To rename this file:
  1. Close Outlook if it is open.
  2. Click Start, point to Find or Search, and then click Files or Folders or All files or folders.
  3. In the Named or the Search for files or folders named box, type Extend.dat in the Look In box, and then select Drive C. If you are using Microsoft Windows 95, Microsoft Windows 98, or Microsoft Windows NT 4.0, select the Include Subfolders option.
  4. Click Find Now or Search Now.
  5. In the Search Results, select the file name, and on the File menu, click Rename.
  6. Change the .dat file extension to .old, and press ENTER. If you have multiple instances of the file, rename each.
  7. Close the Find or Search window.
If the startup error still persists, proceed to the steps in the following subsections, selecting the steps that match your Office installation and configuration choices.

In addition, there are two possible resolutions to this issue. Use the first resolution if you do not want to have Small Business Customer Manager installed on your computer; use the second resolution if you do want it installed.

Small Business Customer Manager Not Installed

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
To modify the registry, follow these steps:
  1. From the toolbar click Start, click Run, type regedit, and then click OK.
  2. Navigate to the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\Addins\SBCM.ADDIN.1

  3. With the Sbcm.addin.1 key selected, press DELETE.
  4. Quit the Registry Editor.

Small Business Customer Manager Installed

If you want the Small Business Customer Manager installed on your computer:
  1. From the toolbar click Start, point to Settings, and click Control Panel.
  2. Double-click Add/Remove Programs.
  3. Select Microsoft Office 2000 Disk 2, and then click Add/Remove. The installer will start up in Maintenance mode.
  4. Click the button next to Add or Remove Features.
  5. Click to expand Small Business Tools and locate Small Business Customer Manager.
  6. Click the red X and then click to select Run from my computer.
  7. Click Update Now. If prompted, insert CD-2 and complete the installation.

MORE INFORMATION

If Office was installed in the default location, it may be necessary for you to complete another troubleshooting step if you want to install Small Business Customer Manager. When attempting to install the program through Maintenance Mode Setup, you may receive the following error message:
Small Business Customer Manager cannot be installed into the same location as a previous version of Access or a previous version of the Access run-time. You must first uninstall any previous version of Access before installing Small Business Customer Manager.
To complete the installation, follow these steps:
  1. Click Start, point to Find or Search, and then click Files or Folders or For Files or Folders.
  2. In the Named or the Search for files or folders named box, type Msaccess.exe.
  3. In the Look in box, select My Computer, and then click Find Now or Search Now.
  4. In Search Results, click to select the file name, and then on the File menu, click Rename.
  5. Rename Msaccess.exe to Msaccess.old.

    If more than one file is found, rename the file that is in the same folder with the other Office programs.
  6. Run the Maintenance mode installation for Office 2000 Disk 2 from the Add/Remove Programs icon in Control Panel, and install Small Business Contact Manager under Microsoft Small Business Tools.
A run-time copy of Microsoft Access will be installed.

If the Small Business Customer Manager was previously installed on the computer and then moved to another location, it may be necessary to register the program to point to the new location. To do so:
  1. Quit any open programs.
  2. Click Start, point to MS-DOS Prompt, or Command Prompt, depending on the version of Microsoft Windows you are using.

    For Microsoft Windows 2000 and Microsoft Windows Millennium Edition (Me), click Start, point to Accessories, and then click MS-DOS Prompt.
  3. At the MS-DOS prompt, type the following and press ENTER:

    cd "\program files\microsoft office\office"

    NOTE: Include the quotation marks.

  4. At the MS-DOS prompt, type the following and press ENTER:

    For Microsoft Windows 95, Microsoft Windows 98, and Windows Me, c:\windows\system\regsvr32.exe sbcmsync.dll

    -or-

    For Windows NT, c:\winnt\system32\regsvr32.exe sbcmsync.dll
  5. You receive the following message:

    DllRegisterServer in sbcmsync.dll succeeded.

  6. Click OK, and then close the MS-DOS prompt.
NOTE: Small Business Customer Manager (SBCM) is not included with Office XP. However, the SBCM that ships with Microsoft Office 2000 can be used with Office XP when the Microsoft Small Business Tools 2000 patch is applied.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

297876 Small Business Customer Manager removed after upgrade to Office XP Small Business Edition


Modification Type:MajorLast Reviewed:1/11/2006
Keywords:kbsetup kbstartprogram kberrmsg kbpending kbprb KB235009