Troubleshooting SBS Fax Events 8218 and 8226 (235003)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.0a
  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q235003

SYMPTOMS

When you are sending or receiving faxes with the Microsoft Small Business Server (SBS) Fax service, you may see the following events logged in the Event Viewer Application log:
Event ID: 8218
Source: NT Fax
Type: Error
Category: Inbound
Description: Unable to receive fax. Unspecified fatal error returned from fax device provider.
Event ID: 8226
Source: NT Fax
Type: Warning
Category: Outbound
Description: Send Failed. An unspecified error occurred. Another attempt will be made to send this fax......

CAUSE

There are several conditions that can cause these types of errors, including but not limited to:
  • The use of a phone line connected through a PBX or other switch.
  • Other devices on the same line as the fax modem, such as other modems, fax machines, answering devices, and so on.
  • Noise on the phone line.
  • The inability of the telephone line to pass the tones used by the modem correctly.
  • Outdated firmware or an outdated .inf file used to install the modem.

RESOLUTION

To troubleshoot these types of errors:
  • Verify that the latest firmware updates from the manufacturer (if available) have been applied to the modem, and that the modem is installed with the latest .inf file from the manufacturer. The updated firmware or .inf file may have improved error handling for the modem.
  • Try a different modem, preferably of a different brand and model, from the Hardware Compatibility List (HCL).
  • Verify that the telephone line connected to the modem is a direct connection from the telephone company and is not running through a PBX or other telephone switchboard.
  • If there are other devices on the same line, remove them.
  • Try connecting another telephone line to the modem to help identify whether the telephone line is contributing to the problem.
  • If none of these suggestions helps, it may be necessary to involve the local telephone company to correct telephone line issues and certify the telephone line. Generally, a standard telephone line is referred to by the telephone company as "POTS" ("Plain Old Telephone Service") and is guaranteed to handle voice communications but not necessarily digital data tones. Your telephone company may be able to make wiring configurations to help with line issues.

MORE INFORMATION

During the initial stages of fax handling by the Fax service, the following sequence of events occurs (this is a basic overview):
  • The modem tells the Fax service that there is an incoming call. The Fax service tells the modem to answer (for an incoming fax) or the Fax service tells the modem to dial a number (for an outgoing fax).
  • The fax modem on the SBS server attempts to negotiate low-level communications with the other fax device.
  • The modem passes a string to the Fax service, notifying the service of success or failure to negotiate.
  • When the negotiation is successful, the Fax service initiates a "modem training" session to determine the best fax speed and compression to use.
  • The fax data is transferred.
  • The Fax service cleans up temporary files and writes archives.
  • The modem is reset for next session.
A T30 protocol trace of an unsuccessful fax job for which an event 8218 or 8226 error occurs indicates that the string that is passed to the Fax service from the modem is "Unknown Error" followed by "Disconnecting." Because there are several conditions that can cause the modem to return this string and the modem has limited resources to devote to debugging a cause, it simply returns "Unknown Error" and Event Viewer displays "An unspecified error occurred."

Some types of modems are more able to deal with poor line conditions and other contributing factors. These modems perform better in most situations. Business-class modems are usually of this caliber, and should be considered when faxing is a business-critical ability.

REFERENCES

For additional information, click the article numbers below to view the articles in the Microsoft Knowledge Base:

195118 SBS: Fax Fails If Sharing Phone Line with Other Devices

246200 SBS: Fax Server Is Unable to Properly Receive Faxes

For information about the Microsoft Windows NT Server 4.0 Hardware Compatibility List, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:11/19/2003
Keywords:kberrmsg kbprb kbtshoot KB235003