OL2000: Imported Personal Address Book Does Not Resolve Names Properly (234505)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q234505

SYMPTOMS

After importing your Personal Address Book (PAB) into your Contacts list, the names are not verified when verifying the address by pressing CTRL+K, or by clicking the Check Names on the toolbar.

CAUSE

This is caused when you use imported PAB entries that had both the first and last name entered in the First Name field.

RESOLUTION

Recreate the contacts that have a blank Last Name field.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

If the PAB entry has the first and last names in the First name field, when they're converted the name is not parsed into the appropriate First name and Last name fields. Since the Last name field is empty, you can no longer use it to resolve the addresses. This gives the impression that the Contacts folder is not being used to check email addresses.

If you have a large number of contacts it may be easier to recreate them if you know exactly which records do not have a populated Last name field. You can isolate those contacts with no last name and are not Distribution lists, by creating a custom view.

Create a Custom View to Display Contacts

To see which contacts do not have a populated Last name field, create a view that shows only contacts with an empty Last name field and are not a Distribution List item.
  1. In the Contacts folder, on the View menu, point to Current View, and then click Define Views.
  2. Click New.
  3. Type a name for your new view, such as No Last Name.
  4. In the Type of view list, click to select Table, and then click OK.
  5. Click Filter.
  6. On the Advanced tab, click Fields, and type Last Name.
  7. Under Condition, click to select is empty. Click Add to List.
  8. Under Define more criteria, type Message Class, and under Condition, click to select doesn't contain. Under Value, type IPM.DistList. Click Add to List.
  9. Click OK.
  10. Click Fields. Add the First Name and Last Name fields, and then move them toward the top of the list. Click OK, OK, and Apply view. You will now see a list of the contacts that will need to be recreated.

Modification Type:MajorLast Reviewed:9/29/2003
Keywords:kbbug KB234505