Profile Error Number 2 When You Log On to Your Computer (233339)



The information in this article applies to:

  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 4.01 for Windows 98 SP 2
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 1
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 2
  • Microsoft Internet Explorer 4.0 for Windows 95

This article was previously published under Q233339
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you log in to a Microsoft Windows 95 or Windows 98 based computer, your user profile may not be loaded and you may receive the following error message:
An error occurred while accessing a file in C:\Windows\Cookies.

Profile Error 2: The file cannot be opened. It may be in use.

Some of your profile settings may not be available.

CAUSE

This issue can occur if Internet Explorer was running at the time you attempted to log on to your computer. This can occur if Internet Explorer has been configured to run as a service by adding an entry to the RunServices key in the registry. Note that Internet Explorer is not designed to be run before you log in to Windows or as a service.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, use any of the following methods.

Method 1

Do not configure Internet Explorer to run before you log on to your computer.

Method 2

Remove the Internet Explorer entry from the RunServices key in the registry:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServices

Method 3

  1. Remove the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ProfileReconciliation

  2. Check the following registry key:

    HKLM\System\CurrentControlSet\Control\Update\UpdateMode

  3. Set the UpdateMode value to decimal "0" to turn this off.

MORE INFORMATION

For information about the RunServices registry key, please see the following article in the Microsoft Knowledge Base:

137367 Definition of the RunOnce Keys in the Registry


Modification Type:MajorLast Reviewed:12/5/2003
Keywords:kbenv kberrmsg kbnetwork kbprb KB233339