PRB: The user name entered is not a valid account (232827)



The information in this article applies to:

  • Microsoft Transaction Server 2.0, when used with:
    • the operating system: Microsoft Windows NT

This article was previously published under Q232827

SYMPTOMS

When attempting to add a user or group to a role of a package, the error
Catalog Error
"The user name entered is not a valid account."

CAUSE

The MTS interface used to add groups or users to roles checks all the listed groups or users whenever a user or group is added or deleted. Therefore, if any user or group is found to contain invalid account information, it will be detected at this point. For instance, invalid NT account information is an account was valid in the past (when it was added to a package role) but has since been deleted from the NT domain and not removed from the MTS package role.

This is confusing to network administrators and programmers alike since it occurrs in concert with adding or deleting a valid account within the role. It helps to understand what is happening behind the graphical user interface. During addition or deletion of a user, MTS first validates every user in the role for validity. If any user account is no longer valid, it ambigously displays this error message even though the user being added or deleted may be a completely valid account.

RESOLUTION

Remove all invalid NT users and groups from the role.

From the position of administration, maintenance, and deployment, the product designers of MTS have strongly encouraged the use of groups in the administration of MTS roles in contrast to using individual user accounts. By doing so, this error is never encountered since the MTS administrtive interface does not iterate through groups to check for validity.

REFERENCES


Modification Type:MajorLast Reviewed:10/19/2000
Keywords:kbprb KB232827