FIX: Error After You Install Microsoft Transaction Server on a Windows 98 Client (230344)



The information in this article applies to:

  • Microsoft Transaction Server 2.0, when used with:
    • the operating system: Microsoft Windows 98

This article was previously published under Q230344

SYMPTOMS

When you export a Microsoft Transaction Server (MTS) package, an executable is created that you can use to configure the MTS application on client computers. If you run this executable on a Microsoft Windows 98 client, you may receive the following error message when you restart the computer:
The setupapi.dll file is linked to missing export cfgmgr32.dll:CM_Get_Log_Config_Priority.
You cannot remove the remote component installation. In addition, certain Control Panel functions may fail, remote access service (RAS) may be disabled, and you may not be able to print. This problem does not occur on Microsoft Windows 95 clients.

CAUSE

The Cfgmgr32.dll and Setupapi.dll files are overwritten by incorrect versions.

RESOLUTION

To resolve this problem, upgrade to Windows NT 4.0 Service Pack 4 or later from the following Microsoft Web site: After you apply the fix to the Windows NT Server, export each of the packages again to re-create the client executables.

If the problem persists, you can manually change the entry in the Template.inf file. You can find the file in the \Program Files\MTS\Mtxclex folder.

Change the following entry from
[Win95SystemFiles] 
setupapi.dll,,,32 
cfgmgr32.dll,,,32
				

to:
[Win95SystemFiles] 
setupapi.dll,,,32 
cfgmgr32.dll,,,16
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

This problem was corrected in Windows NT 4.0 Service Pack 4.

REFERENCES

To download the latest Windows NT Service Pack, see the following Microsoft Web site:

Modification Type:MajorLast Reviewed:7/20/2006
Keywords:kbBug kberrmsg kbfix kbSysAdmin KB230344