Inbox and Internet Explorer Desktop Icons Do Not Function with the Application Security Tool (230338)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition

This article was previously published under Q230338

SYMPTOMS

When you enable the Application Security tool (Appsec.exe) in Windows NT Server 4.0, Terminal Server Edition, the desktop icons for the Windows Messaging client (Inbox) and Microsoft Internet Explorer do not function. If you double-click either icon, the following error message is displayed:
Is not a valid Windows NT application.
No program name is referenced.

CAUSE

The Inbox icon does not function because no entries are included in the Application Security tool authorized program list to allow the Windows Messaging client to run.

The Internet Explorer desktop icon does not function because the MS-DOS naming convention (or 8.3 naming convention) path for Internet Explorer is not in the Application Security tool authorized program list.

The default authorized program list for the Application Security tool includes the path for Internet Explorer in long file name format. The registry contains pointers to Internet Explorer (in multiple Shell\Open\Command keys) in both long file name and MS-DOS 8.3 (short file name) format. The Application Security tool performs a character-for-character comparison of the location in which the file runs. If there are any discrepancies, the program does not run.

RESOLUTION

To resolve this problem, add the following entries to the Application Security tool authorized program list.

For the Windows Messaging client:
  • c:\Program Files\Windows NT\Windows Messaging\exchng32.exe
  • c:\WTSRV\System32\mapisp32.exe
For Internet Explorer:
  • c:\PROGRA~1\Plus!\MICROS~1\iexplore.exe
NOTE: A default installation of Terminal Server on drive C requires these entries.

Modification Type:MajorLast Reviewed:6/24/2004
Keywords:kbprb kbui KB230338