Drive Does Not Have a DMA Check Box (229085)
The information in this article applies to:
- Microsoft Windows Millennium Edition
- Microsoft Windows 98 Second Edition
- Microsoft Windows 98
This article was previously published under Q229085 If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware: SYMPTOMS
When you view properties for drives in Device Manager, the drive may not have a DMA check box.
CAUSE
This issue can occur if a non-ATAPI driver is controlling the drive. For example, SCSI drives do not have this check box, and drives attached to third-party IDE controllers requiring a special miniport (such as the Promise Ultra Wide 66 with the ULTRA66.MPD driver) also do not work.
RESOLUTION
To resolve this issue, use the Esdi_506.pdr file:
- Click Start, point to Settings, click
Control Panel, and then double-click System.
- Click the Device Manager tab, double-click Hard disk controller, click the appropriate hard disk controller, and then click Properties.
- Click the Driver tab, click Update Driver, and then click Next.
- Click Specify the location of the driver (Advanced) to select the driver that you want to use, and then click Next.
- Click Display a list of the drivers in a specific location to select the driver that you want to use, and then click Next.
- Click the driver that matches the date of your operating system, and then click Next.
Note that for Windows 98 the date is 5/11/1998, for Windows 98 Second Edition the date is 4/20/99, and for Windows ME the date is 6/8/2000. - Click Next, click Finish, and then restart your computer.
MORE INFORMATION
The check box for DMA on a drive is a function of the Esdi_506.pdr file
and the configuration manager. It is only available when the
Esdi_506.pdr file is used or when a third-party driver provides it.
Modification Type: | Major | Last Reviewed: | 8/8/2006 |
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Keywords: | kbHardware kbprb kbui KB229085 |
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