You receive an "Internal Error 2343" error message after you remove Lotus Notes and then install Office 2000 (228668)



The information in this article applies to:

  • Microsoft Excel 2000
  • Microsoft Access 2000
  • Microsoft PowerPoint 2000
  • Microsoft Word 2000
  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professoinal
  • Microsoft Office 2000 Standard
  • Microsoft Office 2000 Small Business
  • Microsoft Office 2000 Developer
  • Microsoft FrontPage 2000
  • Microsoft Outlook 2000

This article was previously published under Q228668
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you install Office, you may receive the following error message:
Internal Error 2343: Please contact product support for assistance.
followed by:
Installation ended prematurely because of an error.

CAUSE

This behavior can occur for the following reasons:
  • You removed (uninstalled) Lotus Notes. -or-

  • Lotus Notes is installed, but there are incorrect entries for Lotus Notes in the Windows registry or the Win.ini file.
When you remove Lotus Notes, the uninstall program does not remove certain entries in the Windows registry and the Win.ini file.

This problem only occurs if you removed Lotus Notes, or if Lotus Notes is not installed correctly. Office is installed successfully if the system has an intact installation of Lotus Notes that is installed correctly.

RESOLUTION

To resolve this problem, obtain Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a) full product.

A CD-ROM set that contains the complete version of Microsoft Office 2000 SR-1/SR-1a may be ordered for a minimal cost plus shipping and handling. To order this CD set, call the Microsoft Order Desk at (800) 360-7561. You will be required to provide proof of ownership of a Microsoft Office 2000 retail package to order these CDs.

Alternatively, you can use one of the following methods.

Method 1: Rename Notes.ini

You can temporarily rename the Notes.ini file to avoid this error message.
  • On Microsoft Windows 95, Microsoft Windows 98, or Microsoft Windows Millennium Edition (Me), this file may be located in the following folder

    %systemroot%\system

    where %systemroot% is the drive and path where your system is installed.

  • On Microsoft Windows NT 4.0, Microsoft Windows 2000, or Microsoft Windows 2000 Professional, this file may be located in the following folder

    %systemroot%\system32

    where %systemroot% is the drive and path where your system is installed.
If Method 1 does not work, try the following methods.

NOTE: Renaming the Notes.ini file renders Lotus Notes inoperable. After you install Office 2000, be sure to restore the Notes.ini file to its original name.

Method 2: Download and Run the Internal Error 2343 Utility

Microsoft has a utility to temporarily work around this problem. For additional information about this utility, click the following article number to view the article in the Microsoft Knowledge Base:

234435 OFF2000: Utility to Repair Internal Error 2343 Available

If you choose not to use this utility, you can use either of the following methods to temporarily work around this problem.

Method 3: If Lotus Notes Is Not Installed

First, you must delete the remaining Lotus Notes entries in the Win.ini file. Before you follow these steps, make a backup copy of the Win.ini file that is stored in your Windows folder.

To modify the Win.ini file, follow these steps:
  1. Click Start, and then click Run. In the Open box, type Win.ini.
  2. Click OK.
  3. Locate the [Extensions] section in the Win.ini file. Delete the following entries in the [Extensions] section:

    nsf=c:\notes\Notes.exe ^.nsf
    ns3=c:\notes\Notes.exe ^.ns3
    nsg=c:\notes\Notes.exe ^.nsg
    nsh=c:\notes\Notes.exe ^.nsh
    ns2=c:\notes\Notes.exe ^.ns2
    ntf=c:\notes\Notes.exe ^.ntf

    NOTE: If Lotus Notes was installed to a folder different than the default (c:\notes), these entries will reflect the path where Lotus Notes was installed.

  4. Locate the [LotusMail] section in the Win.ini file. Delete the following entries in the [LotusMail] section:

    Application=Notes
    Program=c:\notes\Notes.exe NoDialogs

    NOTE: If Lotus Notes was installed to a folder different than the default (c:\notes), these entries will reflect the path where Lotus Notes was installed.

  5. On the File menu, click Save.
  6. On the File menu, click Exit.
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


You also must delete the Lotus Notes keys in the registry. To delete the keys, follow these steps:
  1. Quit any programs that are running.
  2. Click Start, and then click Run. In the Open box, type regedit.
  3. Click OK.
  4. In the Registry Editor, navigate to the following key:

    HKEY_CLASSES_ROOT\.nsf

    Delete the .nsf key and all of its subkeys.

  5. Repeat step 4 for the following keys:

    HKEY_CLASSES_ROOT\.nsh
    HKEY_CLASSES_ROOT\.ntf
    HKEY_CLASSES_ROOT\.nsg
    HKEY_CLASSES_ROOT\.ns3
    HKEY_CLASSES_ROOT\.ns2
    HKEY_CLASSES_ROOT\.ndl

    If you do not have any of these keys, skip that key.

  6. Navigate to the following key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes

    Verify that no .nsf key exists. If one does, delete it and all of its subkeys.
  7. Repeat step 6 for each of the following keys:

    .nsh
    .ntf
    .nsg
    .ns3
    .ns2
    .ndl

    If you do not have any of these keys, skip that key.

  8. On the Registry menu, click Exit.

Method 4: If Lotus Notes Is Currently Installed

First, you must verify the Lotus Notes entries in the Win.ini file. Before you follow these steps, make a backup copy of the Win.ini file that is stored in your Windows folder.

To verify the entries in the Win.ini file, follow these steps:
  1. Click Start, and then click Run. In the Open box, type Win.ini.
  2. Click OK.
  3. Locate the [Extensions] section in the Win.ini file. Verify the paths listed in the following entries in the [Extensions] section:

    nsf=c:\notes\Notes.exe ^.nsf
    ns3=c:\notes\Notes.exe ^.ns3
    nsg=c:\notes\Notes.exe ^.nsg
    nsh=c:\notes\Notes.exe ^.nsh
    ns2=c:\notes\Notes.exe ^.ns2
    ntf=c:\notes\Notes.exe ^.ntf

    NOTE: If Lotus Notes was installed to a folder different than the default (c:\notes), use the path where Lotus Notes is installed.

  4. Locate the [LotusMail] section in the Win.ini file. Verify the paths listed in the following entries in the [LotusMail] section:

    Application=Notes
    Program=c:\notes\Notes.exe NoDialogs

    NOTE: If Lotus Notes was installed to a folder different than the default (c:\notes), use the path where Lotus Notes is installed.

  5. On the File menu, click Save.
  6. On the File menu, click Exit.
WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.


You also must verify the Lotus Notes keys in the registry.
  1. Quit any programs that are running.
  2. Click Start and then click Run. In the Open box, type regedit.
  3. Click OK.
  4. In the Registry Editor, navigate to the following key:

    HKEY_CLASSES_ROOT\.nsf\Shell\Open\Command

  5. Double-click (Default) in the Name column.
  6. Verify the path to Notes.exe listed in the Value data box. Change the path if necessary, and then click OK.
  7. Repeat steps 4 through 6 for the following keys:

    HKEY_CLASSES_ROOT\.nsh\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ntf\Shell\Open\Command
    HKEY_CLASSES_ROOT\.nsg\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ns3\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ns2\Shell\Open\Command
    HKEY_CLASSES_ROOT\.ndl\Shell\Open\Command

    If you do not have any of these keys, skip that key.

  8. Navigate to the following key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsf\Shell\Open\Command

  9. Double-click (Default) in the Name column.
  10. Verify the path to Notes.exe listed in the Value data box. Change the path if necessary, and then click OK.
  11. Repeat steps 8 through 10 for each of the following keys:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsh\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ntf\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.nsg\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ns3\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ns2\Shell\Open\Command
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.ndl\Shell\Open\Command

    If you do not have any of these keys, skip that key.

  12. On the Registry menu, click Exit.
NOTE: This problem can also be resolved by temporarily renaming the Notes.ini file. In Windows 95 and Windows 98, this file is located in the \windows\system folder. In Windows NT, this file is located in the \winnt\system32 folder. Please note that renaming the Notes.ini file renders Lotus Notes inoperable. After you install Office 2000, be sure to restore the Notes.ini file to its original name.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was corrected in Microsoft Office 2000 SR-1/SR-1a.

MORE INFORMATION

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

REFERENCES

For more articles about how to troubleshoot specific errors in Office Setup: For more articles with general information about how to troubleshoot Office errors:

Modification Type:MinorLast Reviewed:10/13/2006
Keywords:kbtshoot kbprb kberrmsg kbpending kbsetup KB228668