Large Hypertext Transfer Protocol File Downloads Are Unsuccessful (227219)



The information in this article applies to:

  • Microsoft Proxy Server 2.0

This article was previously published under Q227219
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to download a large file from an Internet Web site using Hypertext Transfer Protocol (HTTP), the Download Complete dialog box may appear, but the file download may actually be unsuccessful.

CAUSE

This problem can occur if your computer has a slow connection to the Internet and you connect to the Internet with Microsoft Proxy Server 2.0.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this problem, edit the registry on the Proxy Server-based computer:
  1. Use Registry Editor (Regedit) to view the following registry key:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Inetinfo\Parameters

  2. Add the following value:

    Value Name: MinFileKbSec
    Data Type: REG_DWORD
    Data Value: 5

  3. Restart your computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:6/11/2002
Keywords:kbbug kbnetwork kbui KB227219