Mail Button in Internet Explorer Does Not Function If Netscape Mail Is the Default Client (227083)



The information in this article applies to:

  • Microsoft Windows 98 Second Edition

This article was previously published under Q227083
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If Netscape Messenger is set as your default mail client, clicking Mail and then clicking Read Mail does not start Netscape Messenger.

CAUSE

This behavior occurs because Netscape Setup does not create a necessary key in the registry. This key is necessary for Internet Explorer to open the mail reader.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue:
  1. Locate the following key in the registry:

    HKEY_LOCAL_MACHINE\Software\Clients\Mail\Netscape Messenger

  2. In the Netscape Messenger key, create a key named "shell" (without the quotation marks).
  3. In the "shell" key, create a key named "open" (without the quotation marks).
  4. In the "open" key, create a key named "command" (without the quotation marks).
  5. In the "command" key, change the data value of the "Default" value to:

    "c:\Program Files\Netscape\Communactior\program\netscape.exe" -mail

    NOTE: You may need to change the path listed above to reflect the correct path to the Netscape.exe file.

Modification Type:MajorLast Reviewed:6/11/2002
Keywords:kb3rdparty kbenv kbprb KB227083