WSP Client Uninstallation Seems to Run Setup (225990)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.5
  • Microsoft Proxy Server 1.0
  • Microsoft Proxy Server 2.0

This article was previously published under Q225990

SYMPTOMS

When you attempt to uninstall the WSP Client software by using the Uninstall command on the Start menu, you may see additional options that seem to indicate that the WSP Client software is being installed, although you can still uninstall the software.

For example, when you click Start, point to Programs, point to MS Proxy Client, click Uninstall, and then click Yes to uninstall the software, the MS Proxy Client Setup dialog box appears. You may see the following options:
  • To replace the previous version in this folder, click OK.
  • To install a new version in a different folder, click the Change Folder button.

CAUSE

The Uninstall routine for the WSP Client software checks the version of the installed software, as well as the version of the Proxy server. If the client computer on which the WSP Client software is installed existed in another local area network (LAN) on which the WSP Client version 1.0 software was used, or if the client existed in a Small Business Server (SBS) version 4.0 LAN that is being updated to SBS 4.5 (which upgrades the WSP Client software to version 2.0), the Uninstall routine prompts you to upgrade to the newer version.

RESOLUTION

Upgrade the existing version of the WSP Client software to the newer version, and then uninstall it. Although you are prompted to reboot after the upgrade, it is not necessary to do so.

STATUS

Microsoft has confirmed that this is a problem in the WSP Client for Proxy Server versions 1.0 and 2.0 running under Microsoft Windows 98, Microsoft Windows 98 Second Edition, Microsoft Windows NT 4.0, and Microsoft Windows 2000.

Modification Type:MajorLast Reviewed:12/3/2003
Keywords:kbprb kbsetup KB225990