OLEXP: "Identity Switch Canceled" when starting Outlook Express (224463)



The information in this article applies to:

  • Microsoft Outlook Express 5.0 for Windows NT 4.0
  • Microsoft Outlook Express 5.0 for Windows 98
  • Microsoft Outlook Express 5.0 for Windows 95

This article was previously published under Q224463
For information about the differences between Microsoft Outlook Express and Microsoft Outlook e-mail clients, click the following article number to view the article in the Microsoft Knowledge Base:

257824 OL2000: Differences Between Outlook and Outlook Express

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you attempt to start Outlook Express 5, one of the following symptoms may occur:
  • You may receive the following error message:
    Identity Switch Canceled. The current identity could not be changed because one of the applications was unable to switch. Close any open dialog boxes in other applications before trying again.
  • Outlook Express 5 does not start.

CAUSE

This issue can occur if the following registry key is missing or damaged:

HKEY_CURRENT_USER\Identities\<Account ID>\<User ID>

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

The User ID string value should be exactly the same as the name of the Account ID. See examples below for clarification.

If the User ID is missing, you can resolve this behavior by adding a string value with the name of "User ID" to the following registry key:

HKEY_CURRENT_USER\Identities\<Account ID>

In this key, <Account ID> represents your identity.

If the User ID is listed, then delete the User ID string value and create a new one using the procedure above. For example, if the following identity is represented, its User ID should have the value data of 12345ABC-ABCD-12A1-ABC1-12A12AB12345:

HKEY_CURRENT_USER\Identities\12345ABC-ABCD-12A1-ABC1-12A12AB12345

If you have more than one identity and need to find out which one you need to edit, look at the Username string value of the HKEY_CURRENT_USER\Identities\<Account ID> key.

Using the example above, to find the Username string value, you would look under the following key:

HKEY_CURRENT_USER\Identities\12345ABC-ABCD-12A1-ABC1-12A12AB12345


Modification Type:MinorLast Reviewed:1/19/2006
Keywords:kberrmsg kbprb KB224463