Unable to Connect to SSL Web Site if Root Authority Is Unknown (224144)



The information in this article applies to:

  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 2
  • Microsoft Internet Explorer 4.01 for Windows 98 SP 2
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 1
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 2

This article was previously published under Q224144

SYMPTOMS

When you use Internet Explorer to connect to a secure sockets layer (SSL) Web site, Internet Explorer may stop responding (hang), and you may receive the following error message or one similar to it:

A connection with the Server could not be established.

CAUSE

This problem can occur if Internet Explorer does not recognize the Root Authority of the SSL Web site, and the Auto Proxy configuration file is configured to return an alternate Proxy Server to the client. When Internet Explorer is using a proxy array and fails to match the Secured Servers Root Authority with the one in it's local store, Internet Explorer internally adds the proxy used to established the connection to the Internet Explorer BadProxy Server list. Internet Explorer then tries to contact the next proxy server in the array, and if the next server is unavailable, Internet Explorer tries to locate the server, and if this is not successful, it generates a navigation error.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Internet Explorer Service Pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:

DateTimeVersionSizeFile namePlatform
03/11/9912:524.72.3515.1100363,000 bytesWininet.dll(x86)


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbenv kberrmsg kbprb KB224144