DVD Device Reports Drive/Disc Error Until Media Is Reinserted (223809)



The information in this article applies to:

  • Microsoft Windows 98

This article was previously published under Q223809

SYMPTOMS

If there is a DVD disc in the DVD player when you start Windows 98 and all of the computer's IRQs are in use, you may receive the following error message when you start the MediaMatics Express player:
No valid drive/disc found
After you eject and reinsert the disc, or you query the drive using Windows Explorer, the problem no longer occurs.

CAUSE

The Installable File System Manager (IFSMGR) is improperly handling Plug and Play rebalancing.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows 98 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date      Time    Version      Size    File name   
   -------------------------------------------------
   03/17/99  09:28p  4.10.2000   185,926  Ifsmgr.vxd
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was corrected in Windows 98 Second Edition.

MORE INFORMATION

This problem is known to occur on the IBM ThinkPad 600E notebook computer using Windows 98 when all IRQs are consumed by hardware. If all of the IRQs are not used, the problem does not occur. For example, the problem does not occur if you disable the notebook's IR port and reboot.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

206071 General Information About Windows 98 and Windows 98 Second Edition Hotfixes


Modification Type:MinorLast Reviewed:10/7/2005
Keywords:kbHotfixServer kbQFE kb3rdparty kbfix kbHardware kbIFS kbprb KB223809