XL2000: Error Message: Current Printer Is Unavailable. Select Another Printer. (223427)



The information in this article applies to:

  • Microsoft Excel 2000

This article was previously published under Q223427

ERROR MESSAGE

When attempting to print, you receive the following error message:
Current printer is unavailable. Select another printer.
NOTE: Microsoft Office 2000 has built-in functionality that allows you to get more information about difficult-to-troubleshoot alerts or error messages. If you want to enable this functionality for this and other error messages in Microsoft Office 2000, please download the Microsoft Office 2000 Customizable Alerts file from the Microsoft Office Update Web site at the following address: NOTE: If you reached this article by clicking the Web Info button in an error message, you already have Customizable Alerts enabled.

CAUSE

Microsoft Excel is having difficulty communicating with the printer. You may receive this message if any of the following conditions is true:
  • The regional settings for your computer are corrupted.
  • If you are using a network printer, the printer driver may require the printer port to be captured.
  • The printer has an invalid network name.
  • The printer driver is corrupted.
  • There is an error on the device= line in the Win.ini file:
    device= HPx LaserJet5Si,PCL5EMS,\\servername\printerid
    						
    For example, the name of the printer driver in the [windows] section of the Win.ini file doesn't match the actual name of the printer driver:

THINGS TO TRY

Try each of the following methods until you find one that fixes the problem.

Method 1: Reset the Regional Settings in Control Panel

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click the Regional Settings icon.
  3. Click the Regional Settings tab. In the drop-down list, choose a different setting (there are several country settings that use English), and then click OK.
  4. If you are prompted to restart your computer, click Yes.
  5. After Windows restarts, return to the Regional Settings Properties dialog box in Control Panel, and reselect your original regional setting.
  6. Click OK, and restart your computer again.

Method 2: Capture a Port for Your Network Printer

Before beginning this procedure, check with your network administrator to make sure you have the correct path for the network printer.
  1. Click Start, point to Settings, and then click Printers.
  2. Right-click the icon for your printer, and click Properties.
  3. Click the Details tab. Click Capture Printer Port.
  4. In the Device box, click a port that's not used by another printer.
  5. In the Path box, type the network path to the printer, and then click OK to close the Capture Printer Port dialog box.
  6. In the Print to the following port box, click the port you chose in step 3, and then click OK.

Method 3: Reinstall the Printer Driver

  1. Click Start, point to Settings, and then click Printers.
  2. Right-click your default printer, and click Delete. If you are asked if you want to remove extra files left on the system, click Yes.
  3. Double-click the Add Printer icon, and follow the instructions to reinstall your printer driver.
When you reinstall your printer driver, the Microsoft Windows operating system corrects many system files and registry keys.

NOTES:
  • If your printer model isn't listed in the Manufacturers and Printers lists, check the Hardware Compatibility List (HCL) for an updated driver. If your printer isn't on the HCL, contact the printer manufacturer for drivers and instructions.
  • If you are on a network, you may need to install the correct printer driver from a network drive. Contact your network administrator for instructions.

Modification Type:MinorLast Reviewed:12/2/2005
Keywords:kbdownload kbfix kbprb KB223427