Cannot Open Service.lck for Writing or Reading (222008)
The information in this article applies to:
- Microsoft FrontPage 98 for Windows
- Microsoft Internet Information Server 3.0
- Microsoft Internet Information Server 4.0
This article was previously published under Q222008 SYMPTOMS
When you attempt to open or list Webs using the FrontPage Server
Extensions running on an IIS 3.0 or 4.0 computer, one of the following
error messages may occur:
Server Error: Cannot open file "e:\InetPub\WWWRoot\_vti_pvt\service.lck"
for writing.
Server Error: Cannot open file "e:\InetPub\WWWRoot\_vti_pvt\service.lck"
for reading.
CAUSE
The error is caused by inappropriate permissions on the Service.lck file
in the Web you are trying to open.
RESOLUTION
To resolve this problem, use one of the following methods: Delete the Service.lck file. (It can become corrupted, especially
by someone opening a Web then ending the network connection rather than
exiting the FrontPage Explorer gracefully.)or Reset the permissions for the Anonymous Account by doing the
following: For IIS 3.0- Click Start and point to Programs.
- Point to Microsoft Internet Information Server.
- Click Internet Service Manager.
- Double-click the WWW Service
- Uncheck the checkbox for Allow Anonymous.
- Click Apply.
- Open the Web in FrontPage.
- When the Web is open re-check the checkbox for Allow
Anonymous.
- Click Apply
- In the FrontPage client, on the Tools menu, click
Permissions.
- On the Users tab, select the radio button so only registered users
have browse access.
- Click Apply.
- When the process has executed, select the radio button so everyone
has browse access, and then click Apply.
You should now be able to open the Web with Anonymous Access turned on.
For IIS 4.0- Click Start and point to Programs.
- Point to Microsoft Windows NT 4 Option Pack
- Point to Microsoft Internet Information Server.
- Click Internet Service Manager.
- Right-click the virtual server that the Web is running on (for
example the Default Web Site), and then click Properties.
- On the Directory Security tab, click Edit in the Anonymous Access
and Authentication Control section.
- Uncheck the checkbox for Allow Anonymous.
- Click OK twice.
- Open the Web in FrontPage.
- When the Web is open, re-check the checkbox for Allow
Anonymous.
- Click OK.
- In the FrontPage client, on the Tools menu, click
Permissions.
- On the Users tab, select the radio button so only registered users
have browse access.
- Click Apply.
- When the process has executed, select the radio button so everyone
has browse access, and then click Apply.
Modification Type: | Major | Last Reviewed: | 11/17/2003 |
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Keywords: | kbprb KB222008 |
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