Installed Third-Party Printer Drivers Not Displayed in Add Printer Wizard (220937)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition

This article was previously published under Q220937

SYMPTOMS

After a third-party printer driver is installed on Terminal Server, it does not appear in the list of available printer drivers when adding additional printers based on that driver. Because of this problem, you must click Have Disk, and specify the location of the third-party printer driver each time you add a printer using that driver.

CAUSE

When the printer driver is added, the system tries to write the OEMx.inf file to the currently logged on user's root drive folder (typically W:\Windows\Inf). If the W:\Windows\Inf folder exists, the file will be created there. If the folder does not exist, the file will not be created.

In either case, because the file is not copied to the correct location (%SystemRoot%\Inf), when the list of available printers is viewed in Add Printer Wizard, the installed third-party printer driver will not be displayed.

RESOLUTION

To work around the problem when installing new printers, perform the following steps:
  1. Put the system into Install mode by typing change user /install at a command prompt.
  2. Create a printer using the third-party printer driver, or update a currently installed printer driver with the third-party printer driver.
  3. Put the system back into Execute mode by typing change user /execute at a command prompt.

STATUS

Microsoft has confirmed that this is a problem in Windows NT Server 4.0, Terminal Server Edition.

Modification Type:MajorLast Reviewed:6/29/2004
Keywords:kbbug kbpending KB220937