Modem Sharing Client Keeps Server's COM Port Open After DUN Connection Is Dropped (218627)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.0a
  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q218627

SYMPTOMS

If a Windows NT Workstation 4.0 client using the Small Business Server (SBS) modem sharing client dials out using a shared modem on the server and that connection is dropped by the dial-in server, the shared COM (modem sharing) port on the SBS server may not be freed up for use by other modem sharing clients. However, other applications on the same client can continue to access the shared modem.

The RAS client keeps the port open (through TAPI), and it shows up as open on the modem sharing server.

What should happen:

When dial-in connection is dropped, the modem sharing connection should be disconnected and the modem should be freed for other use.


What actually happens:

The modem sharing status window still shows connected and the modem cannot be used by other Modem Sharing Clients.


NOTE: This problem does not occur if the Dial-Up Networking (DUN) window is closed or the disconnect is initiated from the Windows NT client side.

CAUSE

This problem is not apparent until you use modem sharing. RAS still holds the port open through TAPI, even after the Dial-Up Networking (DUN) session is disconnected by the dial-in server. This means that other TAPI applications (on the same computer) can use the modem. Therefore, this RAS behavior is not a problem if you do not use modem sharing. However, if the modem is a modem sharing modem, keeping the port open means that the port on the server is open, so other computers cannot use it (but other TAPI applications on the same computer can).

Windows NT DUN should not continue to hold the port after it is disconnected by the other end. DUN knows it was disconnected because the text on the button changes from "Hang-up" to "Dial".

RESOLUTION

To work around this problem, you can do either of the following:
  • Close the DUN connection window and any applications that started the connection.
  • Dial out again from the client and manually disconnect the connection from the client side.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:10/27/2003
Keywords:kbbug KB218627