Permissions on Shared Folders Are Not Granted to Existing Files (218426)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.0a
  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q218426

SYMPTOMS

When you manage permissions on shared folders through the "Control user access to shared folders" tool in the SBS console, the permissions on existing files and folders do not change.

NTFS security defaults to applying these new permissions to existing files.

CAUSE

This behavior occurs because BackOffice Small Business Server (SBS) sets permissions only on new files and folders, and not on existing folders.

RESOLUTION

To resolve this problem:
  1. Double-click My Computer, and then click the drive where the shared folder resides.
  2. Right-click the shared folder, click Properties, click the Security tab, and then click Permissions.
  3. Click Add, click the user you want to add, click the permissions you want to give the user, and then click Add.
  4. The user is displayed in the dialog box.
  5. Select the Replace Existing Files and Apply to Sub Folders check boxes, and then click OK.
This applies permissions to all existing files and subfolders.

STATUS

Microsoft has confirmed that this is a problem in Microsoft BackOffice Small Business Server versions 4.0, 4.0a, and 4.5.

Modification Type:MajorLast Reviewed:10/27/2003
Keywords:kbbug kbnofix KB218426