OL2000: Attachment's Shortcut Menu Does Not Display "Open With" as an Option (218367)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q218367

SYMPTOMS

If you receive an attachment from within either a Rich Text Format (RTF) or HTML message, when you right-click the attachment, Open With may not appear on the shortcut menu. When you click Open to open the file, you receive the following error message, and you cannot open the attachment:
The file, file name, does not have a program associated with it for this action. To create an association, double-click My Computer on your desktop. On the View menu, click Options, and then click File Types.

CAUSE

The file attachment does not have a file name extension that is registered with a program on your computer.

-or-

The file attachment does not have any file name extension. For example, if you save a Notepad file without the txt extension, the file name has no association to the Notepad program when received as e-mail an attachment.

RESOLUTION

Right-click the attachment, and then click Open. When prompted, "What would you like to do with this file?" click Save it to disk instead of Open it. After saving the file to your hard disk, when you right-click the file, Open With should appear on the shortcut menu. This allows you to select the appropriate program on your computer to open the file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MajorLast Reviewed:9/29/2003
Keywords:kbbug kbnofix KB218367