OL2000: LDAP Service Does Not Install When Configured with the Custom Installation Wizard (218324)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q218324

SYMPTOMS

When you configure the Microsoft Office Custom Installation Wizard (CIW) to include the Lightweight Directory Access Protocol (LDAP) service in an Outlook profile, the LDAP service does not appear in the Outlook profile.

CAUSE

This problem occurs because the Messaging Application Programming Interface (MAPI) LDAP service provider is a hidden feature designed to install on first use, and when Outlook creates the profile it does not call the Windows Installer to install this feature.

RESOLUTION

To prevent this problem, make sure the Microsoft Outlook for Windows feature is set to Run all from My Computer in the transform used with the Outlook installation. You can apply this setting in the Set Feature Installation States dialog box of the Client Installation Wizard (CIW).

NOTE: If there are certain Outlook features you do not want to install you can set them to Not Available after you set the Microsoft Outlook for Windows feature to Run all from My Computer. This is because the MAPI LDAP service provider is a hidden child feature of the p rent Microsoft Outlook for Windows feature.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For more information about creating Outlook profiles during a deployment, please visit the following Microsoft Web site to view the Office 2000 Resource Kit:

Modification Type:MajorLast Reviewed:4/17/2006
Keywords:kbbug kbpending KB218324