PRB: Access Violation During Application Setup When File in Use (216368)
The information in this article applies to:
- Microsoft Visual Basic Learning Edition for Windows 5.0
- Microsoft Visual Basic Learning Edition for Windows 6.0
- Microsoft Visual Basic Professional Edition for Windows 5.0
- Microsoft Visual Basic Professional Edition for Windows 6.0
- Microsoft Visual Basic Enterprise Edition for Windows 5.0
- Microsoft Visual Basic Enterprise Edition for Windows 6.0
This article was previously published under Q216368 SYMPTOMS
When running a setup that was created by the Visual Basic Setup Wizard or Package and Deployment Wizard (PDW), the following error message is generated:
<file path and name>
An access violation occurred while copying the file.
where <file path and name> is the name of the file, including the complete path, that Setup is attempting to copy.
CAUSE
Another open program is using the specified file. In some cases, the file may be in use by the operating system.
RESOLUTION
Follow these steps to resolve the problem:
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Verify that the file specified in the error message is redistributable. If the file is not listed as being redistributable, rebuild the distribution removing that file from the setup files.
In Visual Basic 5.0, check the files License.txt and Redist.txt, both of which are located in the "Program files\DevStudio\VB" folder.
In Visual Basic 6.0, check the files Eula.txt in the "Program Files\Microsoft Visual Studio\Common\Setup\1033" folder and Redist.txt in the "Program Files\Microsoft Visual Studio" folder.
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If the file is redistributable, make certain that the user closes all open programs before installing the application. Booting Win9x in Safe Mode prevents most applications from loading automatically at startup, as does holding down the SHIFT key for the duration of the boot. Neither method disables anti-virus software, screen savers, and so forth, so they must be shut down manually if they load the problem DLL.
To determine which program is using the file, use a utility such as DLLView for Windows 9x or Process Explorer (formerly HandleEx) for Windows NT/Windows 2000. Both utilities are available as free downloads from a third-party Web site at the following address:
If all open programs are closed, and the user still receives the error message, the file may be in use by the operating system. In this case, the following alternatives are available to work around the error message:
Modification Type: | Minor | Last Reviewed: | 11/22/2005 |
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Keywords: | kbAppSetup kbGrpDSVB kbprb kbVBp kbVBp500 kbVBp600 kbwizard KB216368 kbAudDeveloper |
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