Dr. Watson Log File May Not Contain Task List (214791)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft Windows NT Workstation 4.0

This article was previously published under Q214791

SYMPTOMS

The Drwtsn32.log file created by Dr. Watson may not contain a task list on systems that use extensible performance counter DLLs, such as Microsoft SQL Server's Sqlctr60.dll.

CAUSE

Dr. Watson uses the system performance counters to generate the task list. It is possible for the size of the returned performance data to change between successive calls to retrieve it. Dr. Watson was not sufficiently tolerant of such a change.

RESOLUTION

A supported fix that corrects this problem is now available from Microsoft, but it has not been fully regression tested and should be applied only to systems experiencing this specific problem. If you are not severely affected by this specific problem, Microsoft recommends that you wait for the next Windows NT 4.0 service pack that contains this fix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:
The English version of this fix should have the following file attributes or later:

   Date      Time                 Size    File Name     Platform
   -------------------------------------------------------------
   01/20/99  12:43a               66,832  Drwtsn32.exe  (x86)
   01/20/99  12:47a               90,384  Drwtsn32.exe  (Alpha)
				

STATUS

Microsoft has confirmed that this is a problem in product x.x.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB214791