"Services Database Is Locked" When Modifying Windows NT Configuration (214762)



The information in this article applies to:

  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0

This article was previously published under Q214762

SYMPTOMS

When you attempt to use a Control Panel tool to change the configuration of a computer running Microsoft Windows NT, you may receive the following error message:
The services database is locked.

CAUSE

This behavior can be caused by a service that is configured to start automatically but cannot be initialized properly.

RESOLUTION

To identify and prevent a service from locking the services database:
  1. Stop all non-essential services. Click Start, point to Settings, click Control Panel, and then double-click Services.
  2. In the list of available services, double-click the service to be modified, click Manual, and then click OK. Repeat this step as necessary with all other non-essential services.

    NOTE: If you receive the locked database error message when attempting this step, you can modify the startup parameter of the individual services by editing the registry.For additional information on how to change the service startup values this way, click the article number below to view the article in the Microsoft Knowledge Base:

    158995 Unable to Change the Startup Parameter When a Service Hangs

  3. Once you have changed all non-essential services to start manually, restart the computer.
  4. If you continue to receive the error message, you can change the essential Windows NT services to manual startup (by using the above steps) to identify the service that is locking the database. Essential Windows NT and Windows 2000 services include:
    • Alerter
    • Computer Browser
    • EventLog
    • License Logging
    • Messenger
    • Net Logon
    • NT LM Security Support Provider
    • Plug and Play
    • Protected Storage
    • Remote Procedure Call (RPC)
    • Server
    • Spooler
    • TCP/IP NetBIOS Helper
    • Workstation

  5. If you do not receive the error message, you can reset each non-essential service back to automatic startup on an individual basis to isolate the service that cannot start. To do this:
    1. Click Start, point to Settings, click Control Panel, and then double-click Services.
    2. Double-click the service to be modified, click Automatic, and then click OK.
    3. Restart the computer.

Modification Type:MajorLast Reviewed:9/9/2002
Keywords:kbenv kberrmsg kbprb KB214762