Plus! 98: Err Msg: Your Setup Location May Be Corrupt or Missing Files (205228)



The information in this article applies to:

  • Microsoft Plus! 98

This article was previously published under Q205228

SYMPTOMS

When you attempt to install Plus! 98, you may receive one of the following error messages:
  • An error has occurred while copying files. Your setup location may be corrupt or missing files. Microsoft Plus! 98 was not fully installed.
    Some files required for setup could not be found. Your setup location may be corrupt or missing files.
    An error has occurred: Setup cannot copy files, your setup location may be corrupt or have missing files.

CAUSE

This behavior can occur for any of the following reasons:
  • The Microsoft Plus! 98 CD-ROM is damaged or dirty.
  • You are using real mode CD-ROM drivers.
  • The root folder on your hard disk is full.
  • You have damaged files in the Temp folder.

RESOLUTION

To resolve this issue, use the following troubleshooting methods in the order in which they are listed. After each method, test to see if the issue is resolved.

Clean the Compact Disc

Clean the Plus! 98 compact disc to remove fingerprints, smudges, and dust, any of which can cause read problems on compact discs. To clean the Plus! 98 compact disc, gently wipe the silver side of the compact disc with a soft, lint-free cotton cloth. Do not use paper cloth, which may scratch the plastic or leave streaks.

NOTE: Wipe the compact disc using a linear motion from the center of the disc outward. Do not use a circular motion.

Verify That You Are Using Protected Mode CD-ROM Drivers

Verify that you are using protected mode (32-bit) drivers for your CD-ROM drive. To do this, follow these steps:

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. Click the Performance tab, and then verify that the File System entry is 32-bit. If the File System entry is Some drives are using MS-DOS compatibility, you may be using real mode (16-bit) CD-ROM drivers. If you may be using real mode CD-ROM drivers, you should contact the manufacturer of your CD-ROM drive to inquire about how to obtain protected mode drivers for your CD-ROM drive.
  4. Click OK, and then close Control Panel.

Check The Number of Files and Folders in the Root Folder

Determine if there are more than 512 files and folders in the root folder of the hard disk on which Microsoft Windows is installed. To do this, follow these steps:
  1. Double-click the My Computer icon on the desktop.
  2. Double-click the hard disk on which Windows is installed.
  3. Verify that there are fewer than 512 files and folders in the root folder. The number of objects in the root folder is displayed in the lower-left corner of the window.

    If there are 512, or nearly 512, objects in the root folder, please see the following article in the Microsoft Knowledge Base for information about how to resolve this issue:

    120138 Errors Creating Files or Folders in the Root Directory

Run ScanDisk

Run ScanDisk to check the hard disk for errors, and fix any problems ScanDisk finds. To do this, follow these steps:
  1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click ScanDisk.
  2. Click your hard disk. If more than one hard disk is installed in the computer, press and hold down the CTRL key, and then click each hard disk.
  3. Click Thorough, and then click Start.
  4. When ScanDisk is finished checking for errors, click Close, and then click Close.

Run Disk Defragmenter

Run Disk Defragmenter to consolidate free disk space. To do this, follow these steps:

  1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click Disk Defragmenter.
  2. Click the hard disk on which Windows is installed, and then click OK.
  3. When Disk Defragmenter is finished, click Yes.

Modification Type:MinorLast Reviewed:8/18/2005
Keywords:kbenv kberrmsg kbprb kbsetup KB205228