BUG: Problems Might Occur When You Change Account Information for SQL Server Cluster (198168)



The information in this article applies to:

  • Microsoft SQL Server 7.0

This article was previously published under Q198168
BUG #: 52892 (SQLBUG_70)

SYMPTOMS

If the cluster group that contains the SQL Server virtual server is taken offline, you cannot successfully change the Microsoft Windows NT account information under which the SQL Server service runs.

WARNING: If you do attempt to change the account information (such as account name or password) while SQL Server is clustered, the service fails to start when you try to bring the cluster group online.

CAUSE

With the cluster group offline, any attempts to change SQL Server service account information cause the password to change but not the account name. As a result, the SQL Server service fails to be validated by Windows NT security, and thus cannot be started successfully.

WORKAROUND

How to Change SQL Service Accounts on a Clustered SQL Server

The proper steps necessary to change the service startup accounts for a clustered SQL Server follow.
  1. Make sure that the SQL Server Virtual Servers resource group is owned by the node on which it was initially installed.
  2. Run the Cluster Failover Wizard and select the option to remove the SQL Server Virtual Server.
  3. Change the service accounts for the MSSQLServer and/or the SQLExecutive or SQLServerAgent to the accounts you want. This account must be a valid domain account and should be in the local Administrators group on both nodes of the cluster. Also, the account must have the following rights:
    1. Act as part of the operating system.
    2. Logon as a service.
    3. Logon locally.
  4. Run the Cluster Failover Wizard to add back the SQL Server Virtual Server.

STATUS

Microsoft has confirmed this to be a problem in SQL Server 7.0.

Modification Type:MajorLast Reviewed:10/16/2002
Keywords:kbBug KB198168