Err Msg: UImport Process Aborted (198100)



The information in this article applies to:

  • Microsoft Site Server 3.0

This article was previously published under Q198100

SYMPTOMS

When you attempt to schedule an Analysis batch job, you may receive one or more of the following error messages:
Error: Couldn't Open Database
Error 70 Permission Denied
Couldn't connect to: <Server Name>

-or-

Error: UImport process aborted
Error 91.
Object Variable or With block variable not set

-or-

Error: UImport process aborted
Error starting Import
Error 424 Object required

CAUSE

This error can occur if the batch file is not set to run under the default SYSTEM account credentials.

RESOLUTION

To resolve this problem, use one of the following workarounds:

Set the credentials for the batch file to run as the local computer's SYSTEM account.

-OR-

Configure the account for this batch file to have Run As Batch Job user rights in User Manager.

-OR-

NOTE: The following steps will help resolve this issue as long as you are still running the Task Scheduler according to the Site Server documentation.
  1. Run DCOMCNFG on the Analysis server. To do this, click Start, point to Run, and type DCOMCNFG (just as if you were opening a CMD window). Scroll down the application list to make sure that the UAS Controller API is there (you do not have to select it).
  2. Click the Default Security tab at the top of the dialog box. This change will affect all applications.
  3. Click Edit Default in the Default Access Permissions frame, add the local Site Server Analysis Administrators group and Allow Launch, and then change the domain to your local computer.
  4. Click Edit Default in the Default Launch Permissions frame, add the local Site Server Analysis Administrators group and Allow Launch, and then change the domain to your local computer.
  5. Restart your server.
NOTES:

This procedure assumes that the user context under which you are running the import is in the Site Server Analysis Administrators group (as the documentation describes).

It is only when both of these permissions are set up and you have restarted the server that the import will then proceed without hitting the permissions error.

You should not have to be logged on for the software to run successfully.

MORE INFORMATION

For additional information regarding this issue, refer to the following Microsoft Knowledge Base articles:

158825 System and User Account Differences with AT Command

-OR-

See the Site Server 3.0 online documentation available at the following path:

Microsoft Site Server Documentation\Analysis\Scheduling Activities\ Changing the Account under which the Scheduler Runs\To change the account under which the Scheduler runs


Modification Type:MajorLast Reviewed:6/30/2006
Keywords:kbprb KB198100