Informix IDS Does Not Start After Installing Service Pack 4 (197796)
The information in this article applies to:
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 4.0
- Microsoft Windows NT Server, Enterprise Edition 4.0
This article was previously published under Q197796 SYMPTOMS
After you install Windows NT 4.0 Service Pack 4 (SP4) on a computer that already
has Informix Dynamic Server (IDS) version 7.2 or earlier installed, the IDS
Insure database service may not start.
CAUSE
The IDS Insure database service is attempting to write to the Event Viewer
security log without the proper security privilege. Fixes included in the
latest service pack require that a process acquire the "Manage auditing and
security log" right before attempting to write to the security log.
RESOLUTION
To resolve this issue, you can:
- Grant the "Manage auditing and security log" right to the user or group,
including a System Account, that requires write access to the security
log. This right is granted by default to the Administrators group, but
it is not explicitly added to any other user or group.
- Acquire the SE_SECURITY_PRIVILEGE before calling RegisterEventSource()
in your source code to write to the security log or write log data to a
different log that is not restricted.
MORE INFORMATION
The third-party products discussed here are manufactured by vendors
independent of Microsoft; we make no warranty, implied or otherwise,
regarding these products' performance or reliability.
Modification Type: | Major | Last Reviewed: | 8/10/2001 |
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Keywords: | kbprb KB197796 |
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