Not Enough Space Available to Upgrade to a Dynamic Disk (197738)
The information in this article applies to:
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Professional
This article was previously published under Q197738 SYMPTOMS
When you try to upgrade a basic disk to a dynamic disk in Windows 2000,
you may receive an error message that says your disk does not have enough
free space for the upgrade.
CAUSE
This problem can occur if there is not enough free space that is not
partitioned at the end of your disk to create the private region database
for the dynamic disk.
RESOLUTION
To work around this problem, use the appropriate method:
Only One Partition on the Disk- Back up all the data on the partition. For information about how to do so, click Start, click Help, click the Index tab, type "nt backup"
(without quotation marks), double-click the Backing Up Files topic, and
then double-click Backing Up Files.
- Start Disk Manager, right-click the partition you backed up in step 1, and then click Delete Partition.
- Right-click the disk you want to upgrade to a dynamic disk, click
Upgrade To Dynamic Disk, and then follow the instructions on the
screen.
- Re-create and reformat the volume, and then restore your data to this
volume.
Multiple Partitions on the Disk- Back up all the data on the last partition on the disk. For information about how to do so, click Start, click Help, click the Index tab, type "nt backup" (without quotation marks), double-click the Backing Up Files topic, and then double-click Backing Up Files.
NOTE: If the last partition on the disk is a logical drive in an
extended partition, you must back up your data, and then delete all
logical drives and the extended partition itself. - Start Disk Manager, right-click the last partition, and then click
Delete Partition.
- Right-click the disk you want to upgrade to a dynamic disk, click
Upgrade To Dynamic Disk, and then follow the instructions on the
screen.
- Re-create and reformat the volume, and then restore your data to this
volume.
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Major | Last Reviewed: | 2/23/2004 |
---|
Keywords: | kberrmsg kbprb KB197738 |
---|
|