Cannot Add New Modem or View Existing Modem Properties (197156)



The information in this article applies to:

  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0

This article was previously published under Q197156

SYMPTOMS

When you double-click the Modems icon in Control Panel, the Install New Modem wizard may not start, or the Modems Properties dialog box may not be displayed.

CAUSE

This behavior can occur if the PnP ISA Enabler service is not started, or if certain files in the Winnt\System32 folder are missing or damaged.

RESOLUTION

To resolve this issue:

  • Verify that the PnP ISA Enabler service is installed. For information on how to do this, see the following Microsoft Knowledge Base article:

    156344 Plug and Play Devices Not Detected or Installed
  • Verify that the Plug and Play service is started. To do this:

    1. Click Start, point to Settings, click Control Panel, and then double-click Services.
    2. Highlight the Plug and Play service. If the Status does not indicate Started, and the Startup mode is not Automatic, click Startup, click Automatic, and then click OK. Click Start, and then click Close.
  • Verify that the following files are located in the Winnt\System32 folder:

    Shell32.dll
    Rpcrt4.dll
    Tapi32.dll
    Setupapi.dll
    Msvcrt.dll
    Lz32.dll
    Comdlg32.dll
    Version.dll
    Cfgmgr32.dll
    Mpr.dll
    Rpcltc1.dll

    If any of these files are missing, reapply the latest Windows NT 4.0 Service Pack. For information on obtaining the service pack, query on the following word in the Microsoft Knowledge Base:

    SERVPACK

Modification Type:MajorLast Reviewed:8/10/2001
Keywords:kbenv kbHardware kbprb KB197156