You receive the "One or more parameter values are not valid" error message when you update a task in Outlook (197036)



The information in this article applies to:

  • Microsoft Outlook 2000
  • Microsoft Outlook 2002
  • Microsoft Office Outlook 2003

This article was previously published under Q197036
For a Microsoft Outlook 98 (CW) version of this article, see 185049.
For a Microsoft Outlook 97 version of this article, see 173306.
NOTE: The procedures in this article only apply if you have installed Outlook with the Corporate or Workgroup option. With this option, you can use Messaging Application Programming Interface (MAPI) services. To determine your installation type, click About Microsoft Outlook on the Help menu. If you have the Corporate or Workgroup installation, you see "Corporate or Workgroup".

SYMPTOMS

When you attempt to update a task in Microsoft Outlook, you may receive the following error message:
Could not complete the operation. One or more parameter values are not valid.

CAUSE

The Microsoft Exchange Server mailbox, or the Tasks folder on the server, is corrupted.

RESOLUTION

Choose one of the following methods to correct this problem. The methods are listed from easiest to most difficult. The first method, if successful, does not result in data loss. The second method results in the loss of task data. Method 3 may result in significant loss of data.

Method 1

  1. Open your Task folder in "Simple List" view.
  2. On the Actions menu, click Save Task Order.
NOTE: Because the "Save Task Order" function can only be applied to a non-filtered view, you must have the current view set to "Simple List" or "Detailed List", and in the default views.

Method 2

This method assumes that you have a copy of the old Exchange Client 5.0 that shipped with Windows 95 or Office 97. Search your hard drive for exchng32.exe to confirm its presence before proceeding.
  1. On the File menu, click Exit and Log Off.
  2. Click the Start button, click Run, type exchng32.exe in the Open box, and then click OK.
  3. Delete the Tasks folder from your mailbox, and then click Exit and Log Off on the File menu.
  4. Click the Start button, click Run, type outlook /resetfolders in the Open box, and then click OK.
This method deletes and recreates the Tasks folder, without affecting any of the other folders on your mailbox.

Method 3

Quit Outlook and have your server administrator remove the mailbox on the server, and then create a new mailbox.

NOTE: Do not import any of the previous data into the new mailbox.

Modification Type:MinorLast Reviewed:6/12/2006
Keywords:kberrmsg kbRepair kbprb KB197036