Compatibility Check Box Is Unavailable During Setup (197011)



The information in this article applies to:

  • Microsoft Internet Explorer 5.5 for Windows NT 4.0
  • Microsoft Internet Explorer 5.01 for Windows NT 4.0
  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.5 for Windows 98
  • Microsoft Internet Explorer 5.01 for Windows 98
  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 5.5 for Windows 95
  • Microsoft Internet Explorer 5.01 for Windows 95
  • Microsoft Internet Explorer 5.0 for Windows 95

This article was previously published under Q197011

SYMPTOMS

When you install or download Internet Explorer 5, the Compatibility check box may be unavailable.

CAUSE

This behavior can occur for any of the following reasons:
  • you are not running Internet Explorer 4.
  • you are installing Internet Explorer 5 from a download that does not include the Compatibility Mode option.

RESOLUTION

To resolve this issue, use the appropriate method:
  • If you are running Internet Explorer 4 and installing Internet Explorer 5 from a download, download Internet Explorer 5 again and select the Compatibility Mode option.

    For additional information about downloading Compatibility mode, please see the following article in the Microsoft Knowledge Base:

    197311 How to Install and Use Compatibility Mode in Internet Explorer 5

  • If you are running Internet Explorer 2.0 or 3.x, upgrade to Internet Explorer 4 before downloading or installing Internet Explorer 5.
  • If you are already running Internet Explorer 5 and you need to download or install Compatibility mode, uninstall Internet Explorer 5 and then install or download it again using the steps in the following Microsoft Knowledge Base article:

    197311 How to Install and Use Compatibility Mode in Internet Explorer 5

    For information about uninstalling Internet Explorer 5, please see the following article in the Microsoft Knowledge Base:

    193934 How to Uninstall Internet Explorer 5 Beta

MORE INFORMATION

Purpose of Compatibility Mode

Some Web content can be affected by changes to the HTML parsing engine or object (scripting) model incorporated into new versions of Internet Explorer. For this reason, Web page authors or developers need to test their content with each version of Internet Explorer for which their content is designed. Prior to Internet Explorer 5, testing Web site compatibility with various versions of Internet Explorer required multiple computers or dual-boot configurations. With Compatibility mode, you can run an Internet Explorer 4-compatible browser side-by-side with Internet Explorer 5. Compatibility mode is designed for testing HTML parsing and script issues and is not intended to be used as a primary Web browser.

Modification Type:MajorLast Reviewed:12/6/2003
Keywords:kbprb kbsetup KB197011