Err Msg: Internet Explorer Could Not Download <Filename>... (196505)
The information in this article applies to:
- Microsoft Internet Explorer 5.5 for Windows Millennium Edition SP 1
- Microsoft Internet Explorer 5.5 for Windows Millennium Edition SP 2
- Microsoft Internet Explorer 5.5 for Windows 98 Second Edition SP 1
- Microsoft Internet Explorer 5.5 for Windows 98 Second Edition SP 2
- Microsoft Internet Explorer 5.5 for Windows 98 SP 1
- Microsoft Internet Explorer 5.5 for Windows 98 SP 2
- Microsoft Internet Explorer 5.0 for Windows 95
- Microsoft Internet Explorer 4.01 for Windows 95 SP 1
- Microsoft Internet Explorer 4.0 for Windows 95
- Microsoft Internet Explorer version 6 for Windows Millennium Edition
- Microsoft Internet Explorer version 6 for Windows 98 Second Edition
- Microsoft Internet Explorer version 6 for Windows 98
- Microsoft Internet Information Services 5.0
- Microsoft Internet Information Services version 5.1
- Microsoft Internet Information Server 4.0
This article was previously published under Q196505 SYMPTOMS
When you attempt to download a Microsoft Excel (.xls, .xlm, .xlc, .xlt),
Microsoft PowerPoint (.ppt), Microsoft Word (.doc, .dot), or Adobe (.pdf)
file from the Internet, you may receive the following error message:
Internet Explorer could not download <filename> from <Web site>.
The downloaded file is not available. This could be due to your
Security or Language Settings or because the server was unable to
retrieve the requested file.
NOTE: Other extensions may be affected as well.
CAUSE
This behavior can occur if the file is located on a computer running
Microsoft Internet Information Server (IIS) 4.0 or 5.0, or Microsoft Windows 2000 with either of the following configurations:
- On the HTTP Header tab in Default Web Site properties, the Enable
Content Expiration option is set to expire immediately.
- On the HTTP Header tab in Default Web Site properties, the Enable
Content Expiration option is set to expire on a past date.
RESOLUTION
To resolve this behavior, contact the Web site administrator and request
that the Enable Content Expiration option be changed to expire on or after
a future date.
How to Set HTTP Headers for Content Expiration
To set content expiration for a Web site, for a virtual folder, or for a file, perform the following steps:
- Start Internet Services Manager, or open the MMC that contains the IIS snap-in.
- In the Internet Information Services dialog box, click to expand * server_name, where server_name is the name of the server.
- Right-click the Web site, folder, or file for which you want to set content expiration (for example, click Default Web Site), and then click Properties.
- Click the HTTP Headers tab.
- Click to select the Enable Content Expiration check box.
- In the Content should box, perform one of the following steps:
- Click Expire after, and then specify a period of time (in minutes, hours, or days) after the content that expires in the appropriate boxes.
Use this option if you want Web content to expire after a specific length
of time. - Click Expire on, and then click an expiration date and time in the appropriate boxes.
Use this option when you want Web content to expire after a specific date
and time.
- Click OK, and then quit Internet Services Manager, or close the IIS snap-in.
Modification Type: | Major | Last Reviewed: | 6/24/2004 |
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Keywords: | kberrmsg kbprb KB196505 |
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