SBS: First E-mail Results in NDR After Upgrade to Exchange Server 5.5 (195744)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.0a
  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q195744

SYMPTOMS

In Small Business Server, after you upgrade Microsoft Exchange Server to Exchange Server 5.5, using either an Exchange Product Upgrade or the SBS 4.5 Product Upgrade, e-mail messages that are sent to an SMTP address (for example, UserX@sample.microsoft.com) may result in a Non-Deliverable Receipt (NDR).

CAUSE

The gethostbyname() API call is failing when the first SMTP message is sent. As a result, the Exchange Server computer is unable to resolve the destination host, making it impossible to deliver the message or messages.

RESOLUTION

To resolve this problem, send an e-mail to an SMTP address, and then force the Internet Mail Service to connect to the ISP by stopping and restarting the Internet Mail Service. This can be done by performing the following steps:
  1. Stop the Microsoft Exchange Internet Mail Service (click Start, point to Settings, click Control Panel, and then double-click Services). Make sure that there is no active connection to the ISP.
  2. Send an e-mail to an SMTP address.
  3. Check to see that the e-mail is sitting in the Outbound queue of the Internet Mail Service: click Start, point to Programs, click Microsoft Exchange, click Microsoft Exchange Administrator, and then start the Internet Mail Service, which is found under the Site/Configuration/Connections object. Double-click the Queues tab.
  4. Start the Internet Mail Service (click Start, point to Settings, click Control Panel, and then double-click Services). This forces the Internet Mail Service to dial and establish a connection to the ISP. At this point, the messages and any other e-mail messages will start to be delivered.

STATUS

Microsoft has confirmed this to be a bug in the Microsoft products listed at the beginning of this article.

MORE INFORMATION

This bug only occurs on BackOffice Small Business Server computers that are connecting to their ISP through a Remote Access Service (RAS). Additionally the bug may occur again anytime the server is restarted.

Modification Type:MajorLast Reviewed:10/10/2003
Keywords:kbbug kbnofix KB195744