OL2000: (CW) Error in Mlcfg32.cpl Checking Service Properties (195246)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q195246
NOTE: These procedures only apply if you have installed Outlook with the Corporate Workgroup/Other option. This option allows you to use Messaging Application Programming Interface (MAPI) services. To determine your installation type, on the Help Menu click About Microsoft Outlook. In About Microsoft Outlook you should see "Corporate" if you have the Corporate Workgroup installation.

SYMPTOMS

When you attempt to list the properties of the Microsoft Exchange Server MAPI service, the Outlook Address Book or the Personal Address Book from the Mail icon in the Microsoft Windows NT 4.0 Control Panel you may receive the following error message:
An error occurred while Windows was working with the Control Panel file <path name>\mlcfg32.cpl.
Following the error, the Mail program quits and you cannot check or change any mail profile settings.

At the same time you may be able to list the properties of these same MAPI services within Outlook by clicking Services on the Tools menu and then clicking Properties for the particular service.

CAUSE

You may have a damaged or outdated Mlcfg32.cpl file.

RESOLUTION

To resolve this problem rename the Mlcfg32.cpl file and run Office Setup using the Repair option. After you rename the file Mlcfg32.cpl, follow these steps to run the Office Repair:

  1. Click Start, point to Settings and then click Control Panel.
  2. In the Windows Control Panel, double-click Add/Remove Programs.
  3. In the list of installed programs, click to select Microsoft Office 2000 and then click Add/Remove.
  4. In Microsoft Office 2000 Setup click Repair Office.
  5. In the Reinstall/Repair dialog, click Repair Errors in My Office Installation, and then click Finish.

Modification Type:MajorLast Reviewed:9/29/2003
Keywords:kbprb KB195246