Custom Import Fails if P&M is Using SQL Server with 850 Char Set (194557)
The information in this article applies to:
- Microsoft Site Server 3.0
This article was previously published under Q194557 SYMPTOMS
If the Site Server 3.0 Personalization and Membership database is running
on SQL Server with the character set configured for "850 Multilingual,"
the Custom Import analysis tool will fail to import user data. During step
2 of the user import, Custom Import issues the following error message.
The import process was stopped because an error occurred while
importing the users. The database indexes for the Membership Directory
are currently inaccessible. The database is currently undergoing
maintenance or the indexes are missing. Please wait and try again or
contact your Membership Server administrator.
CAUSE
The problem is caused by Dsexport.asp on the Membership server, generating
a directory search filter that is invalid if Personalization and
Membership uses a "850 Multilingual" SQL Server database.
RESOLUTION
To resolve this problem, apply the latest Site Server 3.0 service pack.
WORKAROUND
To work around this problem, you can modify the line in the GetFilter()
function in Dspexport.asp on the Personalization and Membership server
that Custom Import runs against.
Original line:
If g_oDNCheck.ValidDN(iSsync) = False Then
Modified line:
If g_oDNCheck.ValidDN(iSsync) = False Or iSsync = 8217 Then
STATUS
Microsoft has confirmed this to be a problem in Site Server version 3.0.
Modification Type: | Major | Last Reviewed: | 3/4/2002 |
---|
Keywords: | kbbug kbSiteServ300sp1fix KB194557 |
---|
|