Outlook Express Fails LDAP Connections Over Slow Links (193498)



The information in this article applies to:

  • Microsoft Outlook Express 4.0 for Windows NT 4.0
  • Microsoft Outlook Express 4.0 for Windows 95
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.0 for Windows 95

This article was previously published under Q193498

SYMPTOMS

When attempting to establish a Lightweight Directory Access Protocol (LDAP) connection, the connection may fail or time out.

CAUSE

This problem can occur because the Wab32.dll file has a hard coded 10-second timeout limit for establishing LDAP connections. This value is insufficient for some cases, particularly if slow links are involved.

RESOLUTION

To resolve this problem, obtain and install Internet Explorer 4.01 Service Pack 2. You can obtain Internet Explorer 4.01 Service Pack 2 from the following Microsoft Web site:

STATUS

Microsoft has confirmed this to be a problem in Microsoft Internet Explorer version 4.0 and Microsoft Outlook Express.

MORE INFORMATION

With the hotfix installed, the timeout value of 10 seconds is no longer hard coded in Wab32.dll. Instead, the Windows Address Book (WAB) reads the timeout value from the following registry location:
   HKEY_CURRENT_USER\Software\Microsoft\WAB
   "LDAP Connection Timeout"=DWORD:10
				
If this registry key and value do not exist, WAB creates it at run-time, and populates it with a default value of 10 seconds.

Modification Type:MinorLast Reviewed:11/15/2005
Keywords:kbenv kbnetwork kbprb kbQFE KB193498