NetMeeting Disconnects from ILS After 2 Minutes (190295)



The information in this article applies to:

  • Microsoft NetMeeting 2.1 for Windows NT 4.0
  • Microsoft NetMeeting 2.0 for Windows NT 4.0
  • Microsoft NetMeeting 2.1 for Windows 95
  • Microsoft NetMeeting 2.0 for Windows 95

This article was previously published under Q190295

SYMPTOMS

When you use NetMeeting 2.0 and 2.1 on a computer running Windows 95, Windows 98, or NT Workstation, the NetMeeting client may disconnect from an Internet Locator server (ILS) after 2 minutes.

CAUSE

The ICMP protocol has been disabled on the ILS server by your ISP.

RESOLUTION

The only workaround at the moment is to disable the AutoDial feature of Dial-Up Networking.

To do this in Microsoft Internet Explorer, on the View menu, click Internet Options and on the Connection tab, click to clear, "Connect to the Internet using a modem."

MORE INFORMATION

Normally, an ILS client such as NetMeeting, refreshes its entry in the ILS server every 2 minutes. On a dial-up client, with AutoDial enabled, NetMeeting sends a PING command to the ILS server just before the LDAP refresh. If your Internet Service Provider (ISP) disables the ICMP protocol on its routers, or if you have routers with the ICMP protocol disabled then the connection will be disconnected. This happens only when NetMeeting is running with both ILS and AutoDial enabled.

When the ICMP message cannot be routed to the ILS server, because ICMP protocol routing has been disabled, NetMeeting will conclude that the connection does not exist and will disconnect from the ILS server.

You can test to see if ICMP is enabled on your network by using the PING command at a command prompt. For example:

PING <ILS servername>

Where <ILS servername> is the IP address or Host Name of the ILS which you have configured. The utility Ping uses the ICMP protocol for "echo request" and "echo reply" messages to determine if a computer is available on the network.

When the AutoDial feature of Dial-Up Networking (DUN) is enabled, an attempt to use the network when the network is disconnected will start the DUN applet to place a call. The LDAP refresh message used by NetMeeting to communicate with the ILS server can cause the applet to start when the network is disconnected (e.g. when the network has just been disconnected but NetMeeting is still running). The LDAP refresh is sent very frequently, which can cause the DUN applet to continue to appear.

To allow the user to continue working in NetMeeting without having the DUN applet start, NetMeeting sends an ICMP ping message only when AutoDial is enabled to detect whether the connection exists or not. Ping is used because it is not hooked by DUN, and so DUN will not launch the applet. If NetMeeting detects that the connection doesn't exist, NetMeeting won't send the LDAP refresh and will inform the user that the server has been disconnected. With NT Workstation the "Remote Access Connection Manager" and the "Remote Access Autodial Manager" services are normally not disabled when you are connected to a LAN, and these services will cause this behavior. The DUN applet will launch in Windows 95 and Windows 98 if the option "Prompt to use Dial-Up Networking" is selected in the DUN properties.

Disable the AutoDial feature of Dial-Up Networking

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click to open Internet.
  3. On the Connection tab, click to select "Connect to the Internet Using the local area network." Click OK to close the window.

Modification Type:MajorLast Reviewed:11/26/2003
Keywords:kbprb KB190295