PRB: Error 429 When Trying to Access an MTS Component (189982)
The information in this article applies to:
- Microsoft Visual Basic Enterprise Edition for Windows 5.0
- Microsoft Transaction Server 2.0
This article was previously published under Q189982 SYMPTOMS
When running a Visual Basic client for a Microsoft Transaction Server (MTS)
component on the server on which MTS is running, you may get the following
error message:
"Run-time error '429': ActiveX component can't create object."
CAUSE
You may have run the MTS remote client setup EXE on the server computer.
RESOLUTION
Do not run the MTS remote client setup EXE on the server computer.
If you have already run the MTS remote client setup EXE on the server, you
must remove the remote client files. In order to do this:
- From the server's Taskbar, select Start, Settings, Control Panel.
- Open Add/Remove Programs.
- Select the "Remote Application" entry that corresponds to your MTS
component, and then click Add/Remove.
You can then use the Transaction Server Explorer to remove and reinstall
the component from the package that will correct the problem.
STATUS
This behavior is by design.
REFERENCES
MTS 2.0 Online Help
For information on creating a Visual Basic database application which
uses components installed under Microsoft Transaction Server, please
see the following article in the Microsoft Knowledge Base:
186342
: HOWTO: Create a 3-Tier App Using VB, MTS and SQL Server
For additional information, please see the following articles in the
Microsoft Knowledge Base:
177394
: HOWTO: Troubleshoot Run-Time Error '429' in DCOM Applications
269330 HOWTO: Troubleshoot DCOM for Visual Basic Client/Server Applications
Modification Type: | Major | Last Reviewed: | 10/17/2003 |
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Keywords: | kbprb KB189982 |
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