SAMR Pipes Cause Problems with Domain Controllers (189356)
The information in this article applies to:
- Microsoft BackOffice Server 4.0
- Microsoft Windows NT Server 4.0
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server, Enterprise Edition 4.0
This article was previously published under Q189356 SYMPTOMS
You may experience one or more of the following:
- Performance problems on domain controllers in the form of lock ups,
crashes, or console freezes.
- Clients may receive the following error messages:
- Semaphore timeout period has expired
- Network path cannot be found.
- Insufficient system resources.
CAUSE
Novell's intraNetWare client for Windows NT Workstation v4.11a and
previous versions can cause SAMR pipes to be left open on domain
controllers throughout the enterprise. This can result in performance
problems with these domain controllers if the number of SAMR pipes open
approaches 2048. Nwgina.dll performs remote API operations including
NetUserGetInfo to get security information from the SAM database located
on a domain controller.
RESOLUTION
Because of performance design reasons, Windows NT does not directly close
an active context associated with an open SAMR file handle used to perform
a remote API operation. Once remote API calls have been performed, the
client must perform local API calls (for example, NetUserModalsGet...)
which indirectly close the handle.
Nwgina.dll has been modified so that the handle references are closed
successfully. Please refer to Novell TID #2939557, "Clients can't connect
to NT server," for more information.
After the limit of 2048 SAMR pipe references is approached, the LSASS
process may fail, requiring the system to be restarted to reinitialize the
LSASS service. However, the problem can be alleviated by monitoring the
system. Perform the following command before LSASS has failed to stop the
server service and close the file handles in question:
Net Stop Server
Net Start Server
Net Start Netlogon
Net Start Computer Browser
NOTE: This command will also stop the dependency services including
Netlogon and the Computer Browser, which must be restarted again as well.
This problem occurs in the Novell intraNetWare Windows NT v4.11 v4.30
Clients. Novell has corrected this problem in the NetWare 5 NT Client v4.50
(Z.E.N.) for Windows NT.
Modification Type: | Major | Last Reviewed: | 10/22/2002 |
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Keywords: | kbprb KB189356 |
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