5250 Print Session May Be Hung in Stuck State, Show Spooling (188991)



The information in this article applies to:

  • Microsoft SNA Server 3.0
  • Microsoft SNA Server 3.0 SP1
  • Microsoft SNA Server 3.0 SP2
  • Microsoft SNA Server 3.0 SP3
  • Microsoft SNA Server 4.0
  • Microsoft SNA Server 4.0 SP1

This article was previously published under Q188991

SYMPTOMS

A 5250 print session may be hung in a stuck state, showing "spooling" for its status in SNA Manager.

CAUSE

The Ppd5250.dll file is not handling properly all errors related to printing. These errors are related to either a failure to communicate to the remote printer, or StartDoc/StartPage errors.

RESOLUTION

SNA Server 3.0

To resolve this problem, obtain the latest service pack for SNA Server version 3.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

184307 How to Obtain the Latest SNA Server Version 3.0 Service Pack


SNA Server 4.0

This problem was corrected in the latest Microsoft SNA Server version 4.0 U.S. Service Pack. For information on obtaining this Service Pack, query on the following word in the Microsoft Knowledge Base (without the spaces):

   S E R V P A C K

STATUS

Microsoft has confirmed that this is a problem in SNA Serverversions 3.0, 3.0 SP1, 3.0 SP2, 3.0 SP3, 4.0, and 4.0 SP1. This problem was first corrected in SNA Server 3.0 Service Pack 4.

Modification Type:MinorLast Reviewed:4/25/2005
Keywords:kbbug kbfix KB188991 kbAudDeveloper