Err Msg: Internet Explorer Cannot Open the Internet Site... (188839)



The information in this article applies to:

  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0
  • Microsoft Internet Explorer 3.02 for Windows NT 4.0
  • Microsoft Internet Explorer 3.01 for Windows NT 4.0
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95
  • Microsoft Internet Explorer 4.0 for Windows 95
  • Microsoft Internet Explorer 3.02 for Windows 95
  • Microsoft Internet Explorer 3.01 for Windows 95
  • the operating system: Microsoft Windows 98

This article was previously published under Q188839

SYMPTOMS

When you attempt to connect to a Secure Web site using Internet Explorer, you may receive the following error message:

Microsoft Windows 95 or Microsoft Windows 98



   Internet Explorer cannot open the Internet site HTTPS://<address>.
   One of the library files needed to run this application cannot be
   found.
				




Microsoft Windows NT 4.0



   Internet Explorer cannot open the Internet site HTTPS://<address>.
   The specified module could not be found.
				

CAUSE

You can receive this error message if the Schannel.dll file is missing or is damaged.

RESOLUTION

To resolve this issue, use the appropriate method:

Windows 98 or Windows 95 with Internet Explorer 4.0, 4.01, or 5



Restore the original Schannel.dll file to the Windows\System folder. To do so, use the following steps:

  1. Click Start, point to Find, click Files Or Folders, type "schannel.dll" (without quotation marks) in the Named box, and then click Find Now.
  2. Right-click the Schannel.dll file in the Windows\System folder, click Rename, type "schannel.old" (without quotation marks), and then press ENTER.
  3. Extract the Schannel.dll file into the Windows\System folder. For information about extracting a file in Windows 95, please see the following article in the Microsoft Knowledge Base: ARTICLE - ID: 129605 TITLE : How to Extract Original Compressed Windows Files For information about extracting a file in Windows 98, please see the System File Checker Tool section in the following Microsoft Knowledge Base article: ARTICLE - ID: 129605 TITLE : How to Extract Original Compressed Windows Files.

Windows 95 with Internet Explorer 3.01 or 3.02



  1. Click Start, point to Find, click Files Or Folders, type "schannel.dll" (without quotation marks) in the Named box, and then click Find Now.
  2. Right-click the Schannel.dll file in the Windows\System folder, click Rename, type "schannel.old" (without quotation marks), and then press ENTER.
  3. Reinstall Internet Explorer version 3.02 from the original media.

Windows NT with Internet Explorer 3.01, 3.02, 4.0, 4.01, or 5



  1. Click Start, point to Find, click Files Or Folders, type "schannel.dll" (without quotation marks) in the Named box, and then click Find Now.
  2. Right-click the Schannel.dll file in the %systemroot%\System32 folder, click Rename, type "schannel.old" (without quotation marks), and then press ENTER.
  3. Create a folder and then copy the service pack executable file into that folder. To do so, use the following steps: a. Click the Start button, point to Programs, and then click MS-DOS Prompt. b. At the command prompt, type the following lines, pressing ENTER after each line: cd\ md servtemp cd servtemp nt4sp3_i.exe /x NOTE: This expands all of the Service pack files without installing them. c. Copy the Schannel.dll file from the service pack folder to the system32 folder. To do so, type the following command, and then press ENTER. copy schannel.dll %winnt dir%\system32

Modification Type:MajorLast Reviewed:2/23/2004
Keywords:kbenv kberrmsg kbprb KB188839