Schedule on Server Can Be Locked by User with Read-Only Access (186441)



The information in this article applies to:

  • Microsoft Schedule+ 7.0
  • Microsoft Schedule+ 7.5

This article was previously published under Q186441

SYMPTOMS

With Microsoft Schedule+, you may get the following error when attempting to modify your own schedule:
The new item could not be inserted. The schedule is being used by someone else. Try again later.

CAUSE

Someone with access permissions to your Schedule file is in the process of receiving data from your file on the server. This activity places a record- level lock on your schedule file while the data is downloading.

WORKAROUND

Ensure that users who have permissions to your schedule do not connect over slow access links, such as telephone lines, or ask that they open your schedule only when necessary rather than keeping it open all the time.

MORE INFORMATION

When others have your schedule open but are not actively using it, the server can still initiate the download when new data is available. This ties up your schedule file even if other users have read-only permissions.

This problem is more likely to occur with a large schedule accessed by several users over slow telephone lines.

For additional information, please see the following article(s) in the Microsoft Knowledge Base:

147512 Schedule+ Locks Schedule File on Server


Modification Type:MinorLast Reviewed:3/4/2004
Keywords:kbbug kbinterop kbusage KB186441